summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gtk-engines-ubuntulooks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gtk-engines-ubuntulooks')
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/Manifest2
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-glib-2.31.patch13
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild45
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/metadata.xml5
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-ubuntulooks/Manifest b/x11-themes/gtk-engines-ubuntulooks/Manifest
new file mode 100644
index 000000000000..098adb386f3e
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/Manifest
@@ -0,0 +1,2 @@
+DIST ubuntulooks_0.9.12-12.diff.gz 8398 RMD160 3e87221e886dbe80be83f8e217932287efc703b1 SHA1 2d94c856f6c6fc615f43f18f1265124ca8fe5d61 SHA256 ac3675103e3bdd7a032e0a0ed0b959c9b2ed48e6d0d57c9ef73713b9b8233b5f
+DIST ubuntulooks_0.9.12.orig.tar.gz 345833 RMD160 451dc8a093f9c4f78e66065c7daddb8af91db9ff SHA1 7270727e42e5b1a790c1010e784ad29ac4430348 SHA256 88e3535c3c7a12c24b09fb057c2a6b52eb0d13f1b2fbdabb4a13bb7e164877fa
diff --git a/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-glib-2.31.patch b/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-glib-2.31.patch
new file mode 100644
index 000000000000..453407f14ee1
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-glib-2.31.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/419395
+
+--- engine/src/animation.c
++++ engine/src/animation.c
+@@ -7,7 +7,7 @@
+ #include "animation.h"
+
+ #ifdef HAVE_ANIMATION
+-#include <glib/gtimer.h>
++#include <glib.h>
+
+ struct _AnimationInfo {
+ GTimer *timer;
diff --git a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
new file mode 100644
index 000000000000..f575683869a2
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+PATCH_LEVEL=12
+MY_PN=${PN/gtk-engines-}
+
+DESCRIPTION="A derivative of the standard Clearlooks GTK+ 2.x engine with more orange approach"
+HOMEPAGE="http://packages.ubuntu.com/search?keywords=gtk2-engines-ubuntulooks"
+SRC_URI="mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz
+ mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_PN}_${PV}-${PATCH_LEVEL}.diff
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch debian/patches
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch #419395
+
+ eautoreconf # update libtool for interix
+}
+
+src_configure() {
+ econf --enable-animation
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+ newdoc debian/changelog ChangeLog.debian
+ find "${ED}"/usr -name '*.la' -type f -exec rm -f {} +
+}
diff --git a/x11-themes/gtk-engines-ubuntulooks/metadata.xml b/x11-themes/gtk-engines-ubuntulooks/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>