summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gnome-icon-theme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gnome-icon-theme')
-rw-r--r--x11-themes/gnome-icon-theme/Manifest2
-rw-r--r--x11-themes/gnome-icon-theme/gnome-icon-theme-3.12.0.ebuild48
-rw-r--r--x11-themes/gnome-icon-theme/metadata.xml5
3 files changed, 55 insertions, 0 deletions
diff --git a/x11-themes/gnome-icon-theme/Manifest b/x11-themes/gnome-icon-theme/Manifest
new file mode 100644
index 000000000000..e1830fa5337a
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-icon-theme-3.12.0.tar.xz 17742624 SHA256 359e720b9202d3aba8d477752c4cd11eced368182281d51ffd64c8572b4e503a SHA512 9dab14a5d30b1fa6655fbd44f15357158dc49ef01d27be678eaed35cb4a9f21546dee2a5d7fb50dac5e3595e161b0be7e7bc79daf47b772f0bb37109b0078bea WHIRLPOOL 261477d6b5fc44d7e80cc73e6dc290c39b7645ff30aafceb59822dbcbec1be5c5b28a1b1c4d906beb343e78467c5cc1d6eb0f709837b611a2df072a47d45ad33
+DIST tango-gentoo-v1.1.tar.gz 29322 SHA256 518efa4257c8e689488399db23397a89f4dcd5990ce537ef6215860ad5606eb0 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045 WHIRLPOOL 9e1635a505ea48f4fe8bdb3b8b3b43cfb9cf99e3204194c51361b198886e719921cfacbc15f9f6407aa7d0c4af178e24c74b998fc370fa2329040e5be1baf153
diff --git a/x11-themes/gnome-icon-theme/gnome-icon-theme-3.12.0.ebuild b/x11-themes/gnome-icon-theme/gnome-icon-theme-3.12.0.ebuild
new file mode 100644
index 000000000000..ecb722f1d06f
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/gnome-icon-theme-3.12.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="|| ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-Sampling-Plus-1.0 )"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/gnome//${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-icon-mapping \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
diff --git a/x11-themes/gnome-icon-theme/metadata.xml b/x11-themes/gnome-icon-theme/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>