summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-06-13 09:45:24 -0500
committerBen Kohler <bkohler@gentoo.org>2024-06-13 09:47:14 -0500
commitf24c18e955065963428f2f43c38c1658d211cffe (patch)
tree3c8406a90234d9c8d469cae12ca3470dc8b4ff54 /x11-terms
parentdev-util/packer: add 1.11.0 (diff)
downloadgentoo-f24c18e955065963428f2f43c38c1658d211cffe.tar.gz
gentoo-f24c18e955065963428f2f43c38c1658d211cffe.tar.bz2
gentoo-f24c18e955065963428f2f43c38c1658d211cffe.zip
x11-terms/guake: add 3.10
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/guake/Manifest1
-rw-r--r--x11-terms/guake/guake-3.10.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-terms/guake/Manifest b/x11-terms/guake/Manifest
index 992e1af1804b..db68e997f409 100644
--- a/x11-terms/guake/Manifest
+++ b/x11-terms/guake/Manifest
@@ -1 +1,2 @@
+DIST guake-3.10.gh.tar.gz 1123390 BLAKE2B ec50c78938c2e24128b9ca35195b4f26dee60ad320d24b4aab91eb427e452aaca401d7adf0091673c7f7e0590cba1bb3f35d5c5c5c56bb422f06e87945e5fc4a SHA512 72e5b7a046ceab0c5fedde25e7baa4e4002edc7f97867db72ed0cacc7347ca5381d74813f1ae1f61167b9c9128d87d60c7b6610b25f7abad024a2e001d3b114a
DIST guake-3.9.0.gh.tar.gz 1118696 BLAKE2B 0c9fdcc5ff11d2f7263154594060a2145cefe678410cebb562dfd355a375019870a240ba4fb3868e69fdb5cf5bf49e73c3c5c2a1acef00251f68feebd8efdeba SHA512 d90e8a12285cd7488fe1132dc5af05d5eccec19a43ae98202631a15d12dfd21c3bda542e5f31ec409481d987a1bd013892c9343e7a74405a784e530efbd83503
diff --git a/x11-terms/guake/guake-3.10.ebuild b/x11-terms/guake/guake-3.10.ebuild
new file mode 100644
index 000000000000..9309c83afad5
--- /dev/null
+++ b/x11-terms/guake/guake-3.10.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+inherit distutils-r1 gnome2-utils optfeature plocale virtualx xdg
+
+PLOCALES="ca cs de el es fa fi fr gl hr hu id it ja ko nb nl pa pl pt_BR ru sv tr uk zh_CN zh_TW"
+
+DESCRIPTION="Drop-down terminal for GNOME"
+HOMEPAGE="https://guake.github.io/"
+SRC_URI="https://github.com/Guake/guake/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]')
+ dev-libs/keybinder:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/vte:2.91[introspection]"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )')
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ sys-devel/gettext"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV} # needed with github's tarball
+
+ local po=($(plocale_get_locales disabled))
+ po=("${po[@]/%/.po}")
+ (( ! ${#po[@]} )) || rm "${po[@]/#/po/}" || die
+
+ emake PREFIX="${EPREFIX}"/usr prepare-install # paths.py.in -> paths.py
+}
+
+python_test() {
+ # - uses /usr/bin/bash if SHELL is not exported
+ SHELL=${SHELL} virtx epytest
+}
+
+python_install() {
+ # use right schema/data dirs, done here so tests don't use the system's
+ sed -e "/^SCHEMA_DIR/s|=.*|= \"${EPREFIX}/usr/share/glib-2.0/schemas\"|" \
+ -e "/def get_default_data_dir/{n;s|=.*|= \"${EPREFIX}/usr/share/guake\"|}" \
+ -i "${BUILD_DIR}/install$(python_get_sitedir)"/guake/paths.py || die
+ python_optimize "${BUILD_DIR}/install$(python_get_sitedir)"/guake/paths.py
+
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install-{locale,schemas}
+
+ dodoc NEWS.rst README.rst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "utmp management support" sys-libs/libutempter
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}