summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-10 05:00:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-10 05:15:49 -0400
commitbe3a70be0cc6343331ee20a29b15900c2cb3db25 (patch)
tree2b9dc52b07d546741b228e739373da199748befe /x11-terms/kitty-terminfo
parentx11-terms/kitty-shell-integration: add 0.29.0 (diff)
downloadgentoo-be3a70be0cc6343331ee20a29b15900c2cb3db25.tar.gz
gentoo-be3a70be0cc6343331ee20a29b15900c2cb3db25.tar.bz2
gentoo-be3a70be0cc6343331ee20a29b15900c2cb3db25.zip
x11-terms/kitty-terminfo: add 0.29.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.29.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 3621be7a447b..fc90c6ad7cc2 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.27.1.tar.xz 5045588 BLAKE2B 2381b3e9af26bb8a4c4358318289e9ef49ba1e38678ef192fd815ced962644671433a80f124579fb593257351cd8e0a61f845975d61d0d33f42b9d470ef130f0 SHA512 484d451b418defc7256319730d623224e3744d6200989d92839c40c951fdb213fe2ef472ddf968f695e499aa6c35d994ad76bb0eb28bca80ec8644b2ead40d56
DIST kitty-0.28.1.tar.xz 7850232 BLAKE2B 18567e54bbd2ac183120122847951744bb8494829911d4c66b5db23488fcc257c895b8d788c1b386ffec832aceb4f691a8a10339be07d43e54957c9c98365a01 SHA512 a8863c8bf5a3c385671d98bd50481ffcd3984e45ee051173eb38de9aac79643e69a312e08b8f655759f3ecdfab4efe38dca39167f5590e482748b5e85dea5537
+DIST kitty-0.29.0.tar.xz 7812720 BLAKE2B bbcc08cb474bf0d9faff0a32244a4ce374da170b78dbeb74bf720ab431c51a8899d2ecaccf45a9063531ea9db51340ddd08bc72cb933cd9c812e89c176ecb32a SHA512 d8d13dea92d21ad113e3f6b056b2ea31514e0893b04c2bac2665821bb66ec10fdadacbf19e22980e0e744ef9d272f2fc2b4981016b182509af2040b6f4267d3c
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.29.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.29.0.ebuild
new file mode 100644
index 000000000000..f217412c7ed0
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.29.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}