summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 13:26:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 13:26:04 -0400
commit420a98b3cf6813a1aad12cfa8ecbfacc573400e9 (patch)
treefda67e7117e551b2370416bee007645ee7962ba6 /x11-terms/kitty-terminfo
parentx11-terms/kitty-terminfo: drop 0.32.1 (diff)
downloadgentoo-420a98b3cf6813a1aad12cfa8ecbfacc573400e9.tar.gz
gentoo-420a98b3cf6813a1aad12cfa8ecbfacc573400e9.tar.bz2
gentoo-420a98b3cf6813a1aad12cfa8ecbfacc573400e9.zip
x11-terms/kitty-terminfo: add 0.33.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.33.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index b80306fc294c..27e47a0b7df1 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.32.2.tar.xz 8103024 BLAKE2B 637449eb655973700493f725846263bfba193729725b6f14490fc44872e191c5e47b272bc3955b5ca47d400a497931be0749d338354ae8a5402fd867f7b941d3 SHA512 245d399366c0b2174bb80d557c08edf49e96a034a3cf33d2027180ef418581cc9bea2566d9ead9f96094bdc01655aeddd251b07b1bc444e7af59c864eb2bcd01
+DIST kitty-0.33.0.tar.xz 8170952 BLAKE2B d98c1070d53b43dacc0aeefa6b0fc46a51528b196b09e875406f30eceddd65256090b6efb2b1b24f485b32db6d36483a9dc725934ad0327412e789e2f01a3574 SHA512 5dad29e7ff0f83dd14138fd32ee3d556214251a5617ef9bd0c8a8b4032e26cf8973752d0b4221e06afd745ae4a12967fc1194f3d053b0e8451cb7ca97360fa35
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.33.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.33.0.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.33.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}