summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-19 01:35:03 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-19 01:39:29 -0500
commitbf2502d4235e07137fa2e8d6ac1d5929cdfbde3a (patch)
tree15890f6c75839034d61bef253e6b04cf1434fc6f /x11-terms/kitty-shell-integration
parentapp-portage/iwdevtools: drop 0.12.9 (diff)
downloadgentoo-bf2502d4235e07137fa2e8d6ac1d5929cdfbde3a.tar.gz
gentoo-bf2502d4235e07137fa2e8d6ac1d5929cdfbde3a.tar.bz2
gentoo-bf2502d4235e07137fa2e8d6ac1d5929cdfbde3a.zip
x11-terms/kitty-shell-integration: add 0.32.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 048fa7633ad0..2d5fb2a6e2ae 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
+DIST kitty-0.32.0.tar.xz 8122660 BLAKE2B 8f2fccb8f233612331b860e0b25aa5a028c2e4d39b5795132351c4a2dff51478b8e42fd3a15bec5f616b4cdb47ad0cc7f636d1961a7f9fad8ede91475e82c29e SHA512 d64f36c20d484724b0215a2ffc9044b83ddaa476926377e6c79226d7d6bd5deffda9964291a99c0df174640fb2fa7df0464435d2cef19304eab7b1d135cc1847
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild
new file mode 100644
index 000000000000..c3b309c79626
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}