summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:35 +0100
commit502bb8f2777b7ecabe478443cfd50bd4d003f01e (patch)
tree48157084bba3eba12dabd746e44066c4557958d2 /x11-plugins
parentx11-plugins/gkrellm-cpupower: Eclass update (diff)
downloadgentoo-502bb8f2777b7ecabe478443cfd50bd4d003f01e.tar.gz
gentoo-502bb8f2777b7ecabe478443cfd50bd4d003f01e.tar.bz2
gentoo-502bb8f2777b7ecabe478443cfd50bd4d003f01e.zip
x11-plugins/gkrellm-bgchanger: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-bgchanger/files/gkrellm-bgchanger-0.1.11-fix-build-system.patch11
-rw-r--r--x11-plugins/gkrellm-bgchanger/gkrellm-bgchanger-0.1.11-r2.ebuild17
2 files changed, 20 insertions, 8 deletions
diff --git a/x11-plugins/gkrellm-bgchanger/files/gkrellm-bgchanger-0.1.11-fix-build-system.patch b/x11-plugins/gkrellm-bgchanger/files/gkrellm-bgchanger-0.1.11-fix-build-system.patch
new file mode 100644
index 000000000000..30eb43d3b83d
--- /dev/null
+++ b/x11-plugins/gkrellm-bgchanger/files/gkrellm-bgchanger-0.1.11-fix-build-system.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@
+ GTK_INCLUDE = `$(GTK_CONFIG) gtk+-2.0 --cflags`
+ GTK_LIB = `$(GTK_CONFIG) gtk+-2.0 --libs`
+
+-GKRELLM_INCLUDE= -I/usr/local/include
++GKRELLM_INCLUDE= -I/usr/include
+
+ INSTALL=install -c -m 755
+
diff --git a/x11-plugins/gkrellm-bgchanger/gkrellm-bgchanger-0.1.11-r2.ebuild b/x11-plugins/gkrellm-bgchanger/gkrellm-bgchanger-0.1.11-r2.ebuild
index 47a89c183f0f..e1853d3a37f8 100644
--- a/x11-plugins/gkrellm-bgchanger/gkrellm-bgchanger-0.1.11-r2.ebuild
+++ b/x11-plugins/gkrellm-bgchanger/gkrellm-bgchanger-0.1.11-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
MY_PN="gkrellmbgchg2"
@@ -12,19 +13,19 @@ DESCRIPTION="Plugin for GKrellM2 to change your desktop background"
HOMEPAGE="http://www.bender-suhl.de/stefan/english/comp/gkrellmbgchg.html"
SRC_URI="http://www.bender-suhl.de/stefan/comp/sources/${MY_P}.tar.gz"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE=""
-RDEPEND="app-admin/gkrellm[X]"
+RDEPEND="app-admin/gkrellm:2[X]"
DEPEND="${RDEPEND}"
-PLUGIN_SO="gkrellmbgchg.so"
-PLUGIN_DOCS="bgchg_info.sh kdewallpaper.sh"
+PATCHES=( "${FILESDIR}"/${PN}-0.1.11-fix-build-system.patch )
+
+PLUGIN_SO=( gkrellmbgchg$(get_modname) )
+PLUGIN_DOCS=( bgchg_info.sh kdewallpaper.sh )
-src_prepare() {
- default
- sed -i "s:local/::" Makefile || die
+src_configure() {
tc-export CC
}