summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmifs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmifs')
-rw-r--r--x11-plugins/wmifs/Manifest3
-rw-r--r--x11-plugins/wmifs/metadata.xml5
-rw-r--r--x11-plugins/wmifs/wmifs-1.3_beta1-r2.ebuild50
-rw-r--r--x11-plugins/wmifs/wmifs-1.4.ebuild38
4 files changed, 96 insertions, 0 deletions
diff --git a/x11-plugins/wmifs/Manifest b/x11-plugins/wmifs/Manifest
new file mode 100644
index 000000000000..48751bc20dc9
--- /dev/null
+++ b/x11-plugins/wmifs/Manifest
@@ -0,0 +1,3 @@
+DIST wmifs-1.3b1.tar.gz 32970 SHA256 771bf1f99ec3ef7d95a06b8cb37059876cf054fec593536794ab9f13facf011d
+DIST wmifs-1.4.tar.gz 28654 SHA256 6f13c030d5e5717eb73778928c3eb527ddda86fccece3a09506940ff333b9bea SHA512 09c444ca26783ba84b1679c311c3d72bc12e5699c4a368b6dd4ef41e248ff9a1c7ffc7c4353cfe9aa6728fcbc7c2573acc64e8df2060a7196c0b0454683c283e WHIRLPOOL 4ceca1557a74846f27d49fb5e05ed73029622e545eba66144b02eb3715fc55320a7c485ece9022188dbceaf9875b6391a1a754315b59611ee9589f5fd7fc562c
+DIST wmifs_1.3b1-11.diff.gz 8117 SHA256 3bd6d6d9021903708692560a403d4aee0cfaa912b5c467a0145b5fc8a6ff5cc0
diff --git a/x11-plugins/wmifs/metadata.xml b/x11-plugins/wmifs/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmifs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmifs/wmifs-1.3_beta1-r2.ebuild b/x11-plugins/wmifs/wmifs-1.3_beta1-r2.ebuild
new file mode 100644
index 000000000000..73294b3fcfad
--- /dev/null
+++ b/x11-plugins/wmifs/wmifs-1.3_beta1-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+MY_PV=${PV/_beta/b}
+S=${WORKDIR}/wmifs.app/wmifs
+DESCRIPTION="Network monitoring dock.app"
+HOMEPAGE="http://www.linux.tucows.com"
+SRC_URI="http://linux.tucows.tierra.net/files/x11/dock/${PN}-${MY_PV}.tar.gz
+ http://http.us.debian.org/debian/pool/main/w/wmifs/${PN}_${MY_PV}-11.diff.gz"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha hppa ~mips ia64 amd64"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # patch to allow for longer interface names
+ # and prettify program output for long names
+ epatch "${WORKDIR}"/${PN}_${MY_PV}-11.diff
+
+ # Honour Gentoo LDFLAGS, see bug #336537
+ sed -i "s/-o wmifs/\$(LDFLAGS) -o wmifs/" Makefile
+}
+
+src_compile()
+{
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install ()
+{
+ dobin wmifs
+ insinto /usr/share/wmifs
+ doins sample.wmifsrc
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+}
diff --git a/x11-plugins/wmifs/wmifs-1.4.ebuild b/x11-plugins/wmifs/wmifs-1.4.ebuild
new file mode 100644
index 000000000000..975aab4f74af
--- /dev/null
+++ b/x11-plugins/wmifs/wmifs-1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Network monitoring dockapp"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/dockapps/${PN}
+
+src_prepare() {
+ # Honour Gentoo LDFLAGS, see bug #336537
+ sed -i "s/-o wmifs/\$(LDFLAGS) -o wmifs/" Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr install
+ dodoc ../BUGS ../CHANGES ../HINTS ../README ../TODO
+}