summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-16 03:15:29 +0000
committerSam James <sam@gentoo.org>2020-09-16 03:15:40 +0000
commite0b3e6a3ee11708abe9eeb8bd8e462741b754155 (patch)
tree7c799eaaf800d0d8e651c0b0f3c17fc2e78f4602 /x11-plugins/pidgin-encryption
parentvirtual/libusb: 1-r2 ppc64 stable (diff)
downloadgentoo-e0b3e6a3ee11708abe9eeb8bd8e462741b754155.tar.gz
gentoo-e0b3e6a3ee11708abe9eeb8bd8e462741b754155.tar.bz2
gentoo-e0b3e6a3ee11708abe9eeb8bd8e462741b754155.zip
x11-plugins/pidgin-encryption: bump to EAPI 7
Closes: https://bugs.gentoo.org/740906 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-encryption')
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild (renamed from x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild)25
1 files changed, 13 insertions, 12 deletions
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
index 561a3df71d68..28f7c2dbaecf 100644
--- a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit flag-o-matic eutils
+inherit flag-o-matic
DESCRIPTION="Pidgin IM Encryption PlugIn"
HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
@@ -14,24 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86"
IUSE="nls"
-RDEPEND="net-im/pidgin[gtk]
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/nss-3.11
+ net-im/pidgin[gtk]
x11-libs/gtk+:2
- >=dev-libs/nss-3.11"
+"
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-glib2.32.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-glib2.32.patch"
+)
src_configure() {
strip-flags
replace-flags -O? -O2
- econf $(use_enable nls)
+ econf $(use_enable nls) --disable-static
}
src_install() {
- emake install DESTDIR="${D}"
+ emake install DESTDIR="${ED}"
dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
}