summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/hexchat-javascript
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/hexchat-javascript')
-rw-r--r--x11-plugins/hexchat-javascript/Manifest2
-rw-r--r--x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild35
-rw-r--r--x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild36
-rw-r--r--x11-plugins/hexchat-javascript/metadata.xml17
4 files changed, 90 insertions, 0 deletions
diff --git a/x11-plugins/hexchat-javascript/Manifest b/x11-plugins/hexchat-javascript/Manifest
new file mode 100644
index 000000000000..295530f8c905
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/Manifest
@@ -0,0 +1,2 @@
+DIST hexchat-javascript-0.3.1.tar.gz 27150 SHA256 42bb9bacd9545df3e76722bbf65322d3f85f820fb86355292d8e1551a3db5223 SHA512 8a59d26d9aa4fba19f3058b646a0a7da4facb936a88cec9a8f7c8f4ff4a865263665377edec5acbc33890786b7d576667d39323ba35e9b0ce05dc4d132a50502 WHIRLPOOL e310c81a968f1fa7fef7fa43f9054e3863edd4d22837c972f6f89b4b3ee4b1e2f3849041d8daf2470f36168134d276dfafa3c8aade5650fe12f05a0439d89ca7
+DIST hexchat-javascript-0.3.2.tar.gz 27542 SHA256 438e2102c4f99386bb9b429f117b9ba6c293e3c708d2c9270716d5ff095a12a8 SHA512 2829ddda5d35e50c4528b56c898c96a51d5b416d55e1631f97104fa8326952ae2bde041d07d9ef652a3b92a7d33ae99307d30605c2deaacd317e71599c9708a0 WHIRLPOOL e6e5f46ad049ca1bdf7147611b789449111fe6ddad7645dd097d0e2812a7ecb5b0040313f665366832db52dfc783f796c868ec740a30ff5a130d4e7124bcf6b7
diff --git a/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild
new file mode 100644
index 000000000000..61eb3076322d
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Javascript interface for HexChat"
+HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
+SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-lang/spidermonkey:0
+ >=net-irc/hexchat-2.9.6[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CXX PKG_CONFIG
+ fi
+}
+
+src_install() {
+ default
+ if use examples ; then
+ dodoc -r examples
+ fi
+}
diff --git a/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
new file mode 100644
index 000000000000..71586dc811f6
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Javascript interface for HexChat"
+HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
+SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-lang/spidermonkey:0
+ >=net-irc/hexchat-2.9.6[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CXX PKG_CONFIG
+ fi
+}
+
+src_install() {
+ dodir /usr/share/appdata
+ default
+ if use examples ; then
+ dodoc -r examples
+ fi
+}
diff --git a/x11-plugins/hexchat-javascript/metadata.xml b/x11-plugins/hexchat-javascript/metadata.xml
new file mode 100644
index 000000000000..ce4ef9ad6518
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <upstream>
+ <maintainer status='active'>
+ <email>tingping@fedoraproject.org</email>
+ <name>TingPing</name>
+ </maintainer>
+ <bugs-to>https://github.com/TingPing/hexchat-javascript/issues</bugs-to>
+ <doc lang='en'>https://github.com/TingPing/hexchat-javascript/wiki</doc>
+ <remote-id type='github'>TingPing/hexchat-javascript</remote-id>
+ </upstream>
+</pkgmetadata>