summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/docker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/docker')
-rw-r--r--x11-plugins/docker/Manifest1
-rw-r--r--x11-plugins/docker/docker-1.5-r1.ebuild37
-rw-r--r--x11-plugins/docker/docker-1.5.ebuild35
-rw-r--r--x11-plugins/docker/files/docker-1.5-makefile.patch45
-rw-r--r--x11-plugins/docker/files/docker-1.5-makefile_rename.patch49
-rw-r--r--x11-plugins/docker/metadata.xml8
6 files changed, 175 insertions, 0 deletions
diff --git a/x11-plugins/docker/Manifest b/x11-plugins/docker/Manifest
new file mode 100644
index 000000000000..c25aa6c61aae
--- /dev/null
+++ b/x11-plugins/docker/Manifest
@@ -0,0 +1 @@
+DIST docker-1.5.tar.gz 14863 SHA256 47629578e89d96d1541c91d040aec4316f03ad6d01dc3eecb8f82a33445c1e4e SHA512 71b47156c31e5db5620612d3444eb298489fb33da296742c10543838e65677daa1b81bb054e6a7f57b9e2adef47406c32040983cb09988d93778a555e72cd861 WHIRLPOOL 2b8fbb60a901f97e71dc31cb876ee42f5b3ff6fe898f4d01b54e98d61352090d561b00fde16f081736ab9882d70281b49102c95a29211e1f0bec1a2f55bd75e1
diff --git a/x11-plugins/docker/docker-1.5-r1.ebuild b/x11-plugins/docker/docker-1.5-r1.ebuild
new file mode 100644
index 000000000000..42f99ee59082
--- /dev/null
+++ b/x11-plugins/docker/docker-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
+HOMEPAGE="http://icculus.org/openbox/2/docker/"
+SRC_URI="http://icculus.org/openbox/2/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile_rename.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "To avoid collision with app-emulation/docker, binary was renamed to wmdocker"
+}
diff --git a/x11-plugins/docker/docker-1.5.ebuild b/x11-plugins/docker/docker-1.5.ebuild
new file mode 100644
index 000000000000..496e01036be2
--- /dev/null
+++ b/x11-plugins/docker/docker-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
+HOMEPAGE="http://icculus.org/openbox/2/docker/"
+SRC_URI="http://icculus.org/openbox/2/${PN}/${P}.tar.gz"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ x11-libs/libX11
+ !app-emulation/docker"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}
diff --git a/x11-plugins/docker/files/docker-1.5-makefile.patch b/x11-plugins/docker/files/docker-1.5-makefile.patch
new file mode 100644
index 000000000000..d788bb630406
--- /dev/null
+++ b/x11-plugins/docker/files/docker-1.5-makefile.patch
@@ -0,0 +1,45 @@
+--- Makefile.orig 2010-03-29 13:57:15.000000000 +0300
++++ Makefile 2010-03-29 13:59:11.000000000 +0300
+@@ -5,12 +5,10 @@
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+
+ # Change this PREFIX to where you want docker to be installed
+-PREFIX=/usr/local
+-# Change this XLIBPATH to point to your X11 development package's installation
+-XLIBPATH=/usr/X11R6/lib
++PREFIX = /usr
+
+ # Sets some flags for stricter compiling
+-CFLAGS=-pedantic -Wall -W -O
++CFLAGS += -pedantic -Wall -W
+
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -24,14 +22,14 @@
+ target=docker
+ sources=docker.c kde.c icons.c xproperty.c net.c
+ headers=docker.h kde.h icons.h xproperty.h net.h version.h
+-extra=README COPYING version.h.in
++extra=README version.h.in
+
+ all: $(target) $(sources) $(headers)
+ @echo Build Successful
+
+ $(target): $(sources:.c=.o)
+- $(CC) $(CFLAGS) -L$(XLIBPATH) -lX11 \
+- `pkg-config --libs glib-2.0` $^ -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -lX11 \
++ `pkg-config --libs glib-2.0` -o $@
+
+ %.o: %.c
+ $(CC) -c $(CFLAGS) `pkg-config --cflags glib-2.0` $<
+@@ -40,7 +38,8 @@
+ sed -e "s/@VERSION@/$(VERSION)/" version.h.in > $@
+
+ install: all
+- install $(target) $(PREFIX)/bin/$(target)
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install $(target) $(DESTDIR)$(PREFIX)/bin/$(target)
+
+ uninstall:
+ rm -f $(PREFIX)/$(target)
diff --git a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
new file mode 100644
index 000000000000..2e742661b11d
--- /dev/null
+++ b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
@@ -0,0 +1,49 @@
+--- Makefile.orig 2015-01-19 20:10:47.762522964 +0100
++++ Makefile 2015-01-19 20:11:11.463545692 +0100
+@@ -5,12 +5,10 @@
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+
+ # Change this PREFIX to where you want docker to be installed
+-PREFIX=/usr/local
+-# Change this XLIBPATH to point to your X11 development package's installation
+-XLIBPATH=/usr/X11R6/lib
++PREFIX = /usr
+
+ # Sets some flags for stricter compiling
+-CFLAGS=-pedantic -Wall -W -O
++CFLAGS += -pedantic -Wall -W
+
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -21,17 +19,17 @@
+ PACKAGE=docker
+ VERSION=1.5
+
+-target=docker
++target=wmdocker
+ sources=docker.c kde.c icons.c xproperty.c net.c
+ headers=docker.h kde.h icons.h xproperty.h net.h version.h
+-extra=README COPYING version.h.in
++extra=README version.h.in
+
+ all: $(target) $(sources) $(headers)
+ @echo Build Successful
+
+ $(target): $(sources:.c=.o)
+- $(CC) $(CFLAGS) -L$(XLIBPATH) -lX11 \
+- `pkg-config --libs glib-2.0` $^ -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -lX11 \
++ `pkg-config --libs glib-2.0` -o $@
+
+ %.o: %.c
+ $(CC) -c $(CFLAGS) `pkg-config --cflags glib-2.0` $<
+@@ -40,7 +38,8 @@
+ sed -e "s/@VERSION@/$(VERSION)/" version.h.in > $@
+
+ install: all
+- install $(target) $(PREFIX)/bin/$(target)
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install $(target) $(DESTDIR)$(PREFIX)/bin/$(target)
+
+ uninstall:
+ rm -f $(PREFIX)/$(target)
diff --git a/x11-plugins/docker/metadata.xml b/x11-plugins/docker/metadata.xml
new file mode 100644
index 000000000000..6a888dd1add1
--- /dev/null
+++ b/x11-plugins/docker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+ Openbox app which acts as a system tray for KDE and GNOME2.
+</longdescription>
+</pkgmetadata>