summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetrus.Z <silencly07@gmail.com>2022-08-21 15:38:03 +0800
committerFlorian Schmaus <flow@gentoo.org>2022-08-23 20:29:09 +0200
commitc243a94dcb19fb88941c99dac51cf57babb9a45d (patch)
tree96cd4a7ac94a97fbb3962ce69708c059c46cf1a1 /x11-misc
parentdev-java/typesafe-config: Stabilize 1.4.2 x86, #866183 (diff)
downloadgentoo-c243a94dcb19fb88941c99dac51cf57babb9a45d.tar.gz
gentoo-c243a94dcb19fb88941c99dac51cf57babb9a45d.tar.bz2
gentoo-c243a94dcb19fb88941c99dac51cf57babb9a45d.zip
x11-misc/rofi: version bump to 1.7.5
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Petrus Zhao <petrus.zy.07@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26940 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.7.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 6ec043f0bb0e..ea1919f315cc 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,3 +1,4 @@
DIST rofi-1.6.1.tar.xz 404372 BLAKE2B b338382104b84f068024eff3a04bed1bbc895d6977204a9abdc55e3b382e6e6a9e5646f6155011b17d43943d9a7a9fb92aa7dca24789b260e73b5e3b134001de SHA512 c9794a7e4921e58ecc5fc7096218203f548efe2a49ffa6971accc12e9172248bda856ad06f8c11ada9abb62b9a43c7fffce1c1be9a3fe1365c94561b170a8b73
DIST rofi-1.7.2.tar.xz 747768 BLAKE2B c6bc6decebe40fdc020d9fc0f4b998cae2c309d5c582af17092a9a54fcd49d6bcc0a05d4c6e24c7fce42ea85c28b219dd5cd88b13aa22c843724cdd38d223e57 SHA512 78605beb4261ce5f930f6b7f80e9350f37ab1b6249675c7b63625a4ea8d22803bcc7c9aaa07aa569b1c0b72692a8499d35e6e24554fc4a7ff23cd107a8355b1a
DIST rofi-1.7.3.tar.xz 755776 BLAKE2B af746e72ce5d09f3815960eb533bf58160c56141a116d1d950db498445e07696d0af2abe36a661ce67178f2040bfba7a39ac6c8eacdfc4db9f75e5f74daf47f5 SHA512 bba9ee25c7ff2168370ad1fd21a2286706f9db1efccdab84c55abd3bfa822ed10d23128388c69c964e81b2c51e1a95b3a3c7ca503a4564d0bdb3a993d8a9553d
+DIST rofi-1.7.5.tar.xz 772952 BLAKE2B 54511f4f793f3ba0b58294daa1d2974228904a637d13d729b0b7d974c0ebf8d0d98514705212bd42500fe90b0685a3515dc67793baa95baefe6dfc0ecdee83c7 SHA512 84cbb8ccef14fdb5d68062b17245fbcb0e9bab46534eb6c7ce532750b86fb33ce6e43ed24cf3c65e553d15b23a201c9168d97d257da4dddeddb0a7c44dd59cc0
diff --git a/x11-misc/rofi/rofi-1.7.5.ebuild b/x11-misc/rofi/rofi-1.7.5.ebuild
new file mode 100644
index 000000000000..4fe9af652772
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs xdg-utils
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb:=
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-wm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
+ $(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.7.0; then
+ elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
+ elog "If you are still using old configuration setup, please convert it to new format manually."
+ elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
+ elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
+ fi
+ done
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}