summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:20:28 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:20:28 +0100
commitc22cce86fdb377818a8653d42c56e55fc0161faa (patch)
tree7d6c21e618ea29377b73b956fd52b4ae28aaddc7 /x11-misc
parentx11-libs/neXtaw: disable static libs (diff)
downloadgentoo-c22cce86fdb377818a8653d42c56e55fc0161faa.tar.gz
gentoo-c22cce86fdb377818a8653d42c56e55fc0161faa.tar.bz2
gentoo-c22cce86fdb377818a8653d42c56e55fc0161faa.zip
x11-misc/lineakd: disable static libs
Closes: https://bugs.gentoo.org/726150 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r2.ebuild11
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r3.ebuild5
2 files changed, 11 insertions, 5 deletions
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r2.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r2.ebuild
index a87eac2fc117..b1d571e4369a 100644
--- a/x11-misc/lineakd/lineakd-0.9.0-r2.ebuild
+++ b/x11-misc/lineakd/lineakd-0.9.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils ltprune multilib
+inherit multilib
MY_P=${P/.0/}
@@ -36,7 +36,10 @@ PATCHES=(
)
src_configure() {
- econf $(use_enable debug) --with-x
+ econf \
+ $(use_enable debug) \
+ --with-x \
+ --disable-static
}
src_install() {
@@ -46,12 +49,12 @@ src_install() {
emake -j1 DESTDIR="${D}" install
- prune_libtool_files
-
dodoc AUTHORS README TODO
keepdir /usr/$(get_libdir)/lineakd/plugins
insinto /etc/lineak
doins lineakd.conf.example lineakd.conf.kde.example
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
index 4848da2c45c0..21a90c825f75 100644
--- a/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
+++ b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
@@ -36,7 +36,10 @@ PATCHES=(
)
src_configure() {
- econf $(use_enable debug) --with-x
+ econf \
+ $(use_enable debug) \
+ --with-x \
+ --disable-static
}
src_install() {