summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-03-31 17:46:58 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-05-09 16:18:22 +0300
commit9efc1695c14477d7853b0f535ab506c0f3e9881e (patch)
tree6f947691aa07e096dea306c703087b6f24a3a756 /x11-misc
parentmedia-video/pipewire: Stabilize 1.0.5 x86, #931629 (diff)
downloadgentoo-9efc1695c14477d7853b0f535ab506c0f3e9881e.tar.gz
gentoo-9efc1695c14477d7853b0f535ab506c0f3e9881e.tar.bz2
gentoo-9efc1695c14477d7853b0f535ab506c0f3e9881e.zip
x11-misc/shutter: add 0.99.5
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/36018 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/shutter/Manifest1
-rw-r--r--x11-misc/shutter/shutter-0.99.5.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/x11-misc/shutter/Manifest b/x11-misc/shutter/Manifest
index d699fffab8e6..99285f181a91 100644
--- a/x11-misc/shutter/Manifest
+++ b/x11-misc/shutter/Manifest
@@ -1 +1,2 @@
DIST shutter-0.99.4.tar.gz 1734992 BLAKE2B 410e73f784f0d83638867132669a00fe89c06af622f3024e52b5b5700c1a431b4ad50f9066c267cd76f9be48ce6ff88eab4348d2d4dff28b4ae7e0267eb7bc41 SHA512 57f7fdc1066375942bd1a9db381a8ba6f24fafbd5e0853a4dd19016438ec2f3cb039ebe90038d282bc07f6e45af9cdbb6f180f55e43357231b41818b8555347b
+DIST shutter-0.99.5.tar.gz 1736757 BLAKE2B b861d4c71295ceb1e8a2d268e57babccb8a832245ffb18410c19b20bb5aca56358e00cb4e578f3b8dfcd15e4c318beb7ed873a86094de522deed7f4b2e33b58c SHA512 524e135191a324f7da890922c98646c7cd83a714a3b1dc14f2ba9910f8a90f5c6c527a5c857888c2be93120a7b242e435664c8af45792d36b66d7642fda50371
diff --git a/x11-misc/shutter/shutter-0.99.5.ebuild b/x11-misc/shutter/shutter-0.99.5.ebuild
new file mode 100644
index 000000000000..1bc51eaa128f
--- /dev/null
+++ b/x11-misc/shutter/shutter-0.99.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature prefix xdg
+
+DESCRIPTION="Feature-rich screenshot program"
+HOMEPAGE="https://shutter-project.org/"
+SRC_URI="https://github.com/shutter-project/shutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/perl
+ dev-libs/libayatana-appindicator
+ dev-perl/Carp-Always
+ dev-perl/libxml-perl
+ dev-perl/Glib-Object-Introspection
+ dev-perl/GooCanvas2
+ dev-perl/GooCanvas2-CairoTypes
+ dev-perl/Gtk3
+ dev-perl/Gtk3-ImageView
+ dev-perl/File-DesktopEntry
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/JSON
+ dev-perl/File-Copy-Recursive
+ dev-perl/File-MimeInfo
+ dev-perl/Locale-gettext
+ dev-perl/Moo
+ dev-perl/Net-DBus
+ dev-perl/Number-Bytes-Human
+ dev-perl/Pango
+ dev-perl/Proc-Simple
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ virtual/imagemagick-tools[perl]
+ x11-libs/libwnck:3[introspection]
+"
+BDEPEND="
+ sys-devel/gettext
+ test? ( dev-perl/Test-MockModule )
+"
+
+src_prepare() {
+ hprefixify bin/shutter
+ default
+}
+
+src_test() {
+ prove -I share/shutter/resources/modules/ -I t/lib t -r || die
+}
+
+src_install() {
+ dobin bin/shutter
+ dodoc README
+ domenu share/applications/shutter.desktop
+ doicon share/pixmaps/shutter.png
+ doman share/man/man1/shutter.1
+
+ insinto /usr/share
+ doins -r share/shutter
+ doins -r share/locale
+ doins -r share/icons
+
+ insinto /usr/share/metainfo
+ doins share/metainfo/shutter.metainfo.xml
+
+ # .po doesn't belong to installed system, only .mo
+ rm -r "${ED}"/usr/share/shutter/resources/po || die
+
+ # shutter executes perl scripts as standalone scripts, and after that "require"s them.
+ find "${ED}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod +x {} + \
+ || die "failed to make plugins executables"
+ find "${ED}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
+ -name "*.pm" -exec chmod +x {} + || die "failed to make upload plugins executables"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "writing Exif information" media-libs/exiftool
+ optfeature "image hostings uploading" "dev-perl/JSON-MaybeXS dev-perl/Path-Class"
+ optfeature "WebP support" gui-libs/gdk-pixbuf-loader-webp
+}