summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2019-11-17 11:23:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-18 08:14:14 +0200
commit99ff435c78a24e3088f11f7a1d565404bc82034d (patch)
treeea37bce4aeaa5e2250d988c054687e86773f340a /x11-misc
parentapp-dicts/myspell-nl: add territory locale formatted entries (diff)
downloadgentoo-99ff435c78a24e3088f11f7a1d565404bc82034d.tar.gz
gentoo-99ff435c78a24e3088f11f7a1d565404bc82034d.tar.bz2
gentoo-99ff435c78a24e3088f11f7a1d565404bc82034d.zip
x11-misc/libinput-gestures: version bump to 2.48, sort revdep
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/13685 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/libinput-gestures/Manifest1
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.48.ebuild56
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-9999.ebuild4
3 files changed, 59 insertions, 2 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index f6afd4314c98..6ff096150a2c 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1,2 +1,3 @@
DIST libinput-gestures-2.41.tar.gz 18098 BLAKE2B 792ebab29cb5ea24cbb696eac6ed651632db4079d8470784f45a1055d99c9672f8bfa7e8ddc08b80417c91a47f540fdf13f7a071c73bb7a654ce66508f181a38 SHA512 7f718275d5b4b722df52adb597f0344427500ca730c154cf6fd3de2f06d7081e6214cc954addc34594f17f10c70d081fecbfc1a22d16726b6ea820019dae6d83
DIST libinput-gestures-2.45.tar.gz 18645 BLAKE2B 555556e683eac1944407e169d7ad9cac23fe3b91b781dbba9367b86bd73556d3e0aa550008563c4c7f6726a12dc6ac4a458f9dae5782db0d8a23dc2f12a897f8 SHA512 27eac34826c3f02a16bb5c6c892e2bcc12ed27a8a1cb64bde945e869161f30701240deebbd278318f418319f1c98be13dc90eb95f9354f624939af4b7471762f
+DIST libinput-gestures-2.48.tar.gz 22858 BLAKE2B 67fada253a0d02791e14c6c2175f37f75c2e4ff04b04360070d1c045cf064a9d7b362c28a1e8130e6cc435bd487370c69ded3af41d53b935f7024d722aca9593 SHA512 6ad510f2067ab6cef9c9a94f1c300fe91aa811904a0e85209dc06b3afdd4a2be8ae7bda8ccb40210cc59c3758e3b14b53285f7c3c29c6982a3894952b678a840
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.48.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.48.ebuild
new file mode 100644
index 000000000000..2f4a08da79af
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.48.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libinput-1.8.0
+ x11-misc/wmctrl
+ x11-misc/xdotool"
+DEPEND=">=dev-libs/libinput-1.8.0
+ dev-util/desktop-file-utils"
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
+src_test() { :; }
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
index 213fbc54cfab..2f4a08da79af 100644
--- a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
+++ b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
@@ -24,8 +24,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
>=dev-libs/libinput-1.8.0
- x11-misc/xdotool
- x11-misc/wmctrl"
+ x11-misc/wmctrl
+ x11-misc/xdotool"
DEPEND=">=dev-libs/libinput-1.8.0
dev-util/desktop-file-utils"