summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-06-17 14:26:54 -0400
committerMike Gilbert <floppym@gentoo.org>2018-06-17 14:30:01 -0400
commit961b4df26664b11040729a6ee02f53b90c1ebe21 (patch)
tree512543271684a5b82ddf1fa57368c50999f7dbe0 /x11-misc
parentdev-ruby/asciidoctor: cleanup (diff)
downloadgentoo-961b4df26664b11040729a6ee02f53b90c1ebe21.tar.gz
gentoo-961b4df26664b11040729a6ee02f53b90c1ebe21.tar.bz2
gentoo-961b4df26664b11040729a6ee02f53b90c1ebe21.zip
x11-misc/xdg-utils: fix xdg-open with pcmanfm
Closes: https://bugs.gentoo.org/658186 Package-Manager: Portage-2.3.40_p14, Repoman-2.3.9_p246
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdg-utils/files/xdg-utils-1.1.3-xdg-open-pcmanfm.patch21
-rw-r--r--x11-misc/xdg-utils/xdg-utils-1.1.3-r1.ebuild (renamed from x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild)11
2 files changed, 26 insertions, 6 deletions
diff --git a/x11-misc/xdg-utils/files/xdg-utils-1.1.3-xdg-open-pcmanfm.patch b/x11-misc/xdg-utils/files/xdg-utils-1.1.3-xdg-open-pcmanfm.patch
new file mode 100644
index 000000000000..1f6cc29ab059
--- /dev/null
+++ b/x11-misc/xdg-utils/files/xdg-utils-1.1.3-xdg-open-pcmanfm.patch
@@ -0,0 +1,21 @@
+From 31525d3855f876ddf2e29091b2e8d376f923e09e Mon Sep 17 00:00:00 2001
+From: Rex Dieter <rdieter@gmail.com>
+Date: Thu, 24 May 2018 14:40:53 -0500
+Subject: xdg-open: better pcmanfm check (BR106636,BR106161)
+
+diff --git a/scripts/xdg-open.in b/scripts/xdg-open.in
+index 630e63e..bf9da4c 100644
+--- a/scripts/xdg-open.in
++++ b/scripts/xdg-open.in
+@@ -451,7 +451,7 @@ open_lxde()
+ {
+
+ # pcmanfm only knows how to handle file:// urls and filepaths, it seems.
+- if pcmanfm --help >/dev/null 2>&1 -a is_file_url_or_path "$1"; then
++ if pcmanfm --help >/dev/null 2>&1 && is_file_url_or_path "$1"; then
+ local file="$(file_url_to_path "$1")"
+
+ # handle relative paths
+--
+cgit v1.1
+
diff --git a/x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild b/x11-misc/xdg-utils/xdg-utils-1.1.3-r1.ebuild
index af9be47a61ba..178f20fca728 100644
--- a/x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild
+++ b/x11-misc/xdg-utils/xdg-utils-1.1.3-r1.ebuild
@@ -34,6 +34,10 @@ DOCS=( README RELEASE_NOTES TODO ) # ChangeLog is bogus, see git instead
RESTRICT="test" # Disabled because of sandbox violation(s)
+PATCHES=(
+ "${FILESDIR}"/xdg-utils-1.1.3-xdg-open-pcmanfm.patch
+)
+
#S=${WORKDIR}/${MY_P}
src_prepare() {
@@ -42,14 +46,9 @@ src_prepare() {
# to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
# all the files
if [[ -d "${WORKDIR}/patch" ]]; then
- eapply patch
+ eapply "${WORKDIR}/patch"
fi
eautoreconf
-
- if pushd scripts &>/dev/null ; then
- make scripts-clean
- popd &>/dev/null
- fi
}
src_configure() {