summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 13:40:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 14:46:29 +0100
commit8e8f06ff0b223e5188e05153436597c25d4edeba (patch)
tree796802d5676373fce5c9ff4d9f9d36a818003e0c /x11-misc
parentdev-ruby/elasticsearch-api: add missing test dependency (diff)
downloadgentoo-8e8f06ff0b223e5188e05153436597c25d4edeba.tar.gz
gentoo-8e8f06ff0b223e5188e05153436597c25d4edeba.tar.bz2
gentoo-8e8f06ff0b223e5188e05153436597c25d4edeba.zip
x11-misc/copyq: add 9.1.0
Closes: https://bugs.gentoo.org/934459 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/copyq/Manifest1
-rw-r--r--x11-misc/copyq/copyq-9.1.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/x11-misc/copyq/Manifest b/x11-misc/copyq/Manifest
index c9b144ae31ea..95aaddd98bc5 100644
--- a/x11-misc/copyq/Manifest
+++ b/x11-misc/copyq/Manifest
@@ -1 +1,2 @@
DIST copyq-7.1.0.tar.gz 3351093 BLAKE2B 758271f6bb54760372b8b5ab84de7c91af874bd72a22c8c22d338705869eab5500fde90808b4bf1288f8bdbad11163283637b81d85c09ccf0d734286dee605b6 SHA512 4320095ab75c361cc3d553c7817951eb6e74d47223f62bf6c1722e0f0b0d3ff59a1762354cf46fe0de064d516d60a467bff9ad9143b12016fc3f9e62139d3909
+DIST copyq-9.1.0.tar.gz 3417507 BLAKE2B 582b532cdc0c01976fa52b01b3656902fc392ce5785145230efe7f42da8920553161e8bd44b1fcbd9ba2f7d4a8169ac017474f1dd8a34874aec1919e442326a6 SHA512 d87964b876de28be860a17490d9816f5224a25565f84916ee4ca39f83d2e7c5d57dafdf9f54667c43fd93d232e1e1f1f32064e6435aad6abab086398e6ae246d
diff --git a/x11-misc/copyq/copyq-9.1.0.ebuild b/x11-misc/copyq/copyq-9.1.0.ebuild
new file mode 100644
index 000000000000..e715321c54ab
--- /dev/null
+++ b/x11-misc/copyq/copyq-9.1.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature virtualx xdg
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://hluk.github.io/CopyQ/ https://github.com/hluk/CopyQ/"
+SRC_URI="https://github.com/hluk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CopyQ-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="notification test X"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/wayland
+ dev-qt/qtbase:6[gui,network,widgets,xml(+)]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
+ dev-qt/qtwayland:6
+ X? (
+ dev-qt/qtbase:6=[X]
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ )
+ notification? (
+ kde-frameworks/knotifications:6
+ kde-frameworks/kstatusnotifieritem:6
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ dev-qt/qttools:6[linguist]
+ dev-util/wayland-scanner
+ test? (
+ app-crypt/gnupg
+ x11-wm/openbox
+ )
+"
+
+# used in tests
+PATCHES=( "${FILESDIR}/${PN}-7.1.0-support-plugin-dir-envvar-r1.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_QT6=ON
+ -DPLUGIN_INSTALL_PREFIX="${EPREFIX}/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_NATIVE_NOTIFICATIONS=$(usex notification)
+ -DWITH_TESTS=$(usex test)
+ -DWITH_X11=$(usex X)
+ )
+
+ cmake_src_configure
+}
+
+my_src_test() {
+ # Don't rerun tests and more logs
+ local -x COPYQ_TESTS_RERUN_FAILED=0
+ local -x COPYQ_LOG_LEVEL=DEBUG
+
+ # Skip test that require network
+ local -x COPYQ_TESTS_NO_NETWORK=1
+
+ # Less noise from trying the wayland plugin
+ local -x QT_QPA_PLATFORM=xcb
+
+ # Make sure copyq doesn't use system installed plugins which may be incompatible.
+ local -x COPYQ_PLUGIN_DIR="${BUILD_DIR}/plugins"
+
+ # In case the users current system confuses the notification integration
+ unset KDE_FULL_SESSION XDG_CURRENT_DESKTOP
+
+ mkdir "${HOME}"/.gnupg || die
+
+ ebegin "Starting Openbox"
+ openbox & # upstream uses Openbox and it doesn't fail like IceWM
+ sleep 5
+ eend 0
+
+ "${BUILD_DIR}"/copyq tests
+}
+
+src_test() {
+ # local -x QT_QPA_PLATFORM=offscreen # TODO: make it work
+ virtx my_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "encryption support" app-crypt/gnupg
+}