summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-18 17:33:52 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-18 17:39:11 +0800
commit2098ffeba8064321b19459b3773ab48be33ab1ca (patch)
tree5f7695a1b864664d30ffbff38f9d21897d926c81 /x11-misc/x11vnc
parentsci-geosciences/grass: Drop keywords that need more deps to be keyworded too (diff)
downloadgentoo-2098ffeba8064321b19459b3773ab48be33ab1ca.tar.gz
gentoo-2098ffeba8064321b19459b3773ab48be33ab1ca.tar.bz2
gentoo-2098ffeba8064321b19459b3773ab48be33ab1ca.zip
x11-misc/x11vnc: bump to -0.9.13_p20150627 via the gentoo bug
disable the option --disable-crypt in new snapshot, ebuild submitted by proxy maintainer Gentoo bug: #548434 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/Manifest1
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13_p20150627.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/x11vnc/Manifest b/x11-misc/x11vnc/Manifest
index d072f1941f93..0ad1bcfa08d0 100644
--- a/x11-misc/x11vnc/Manifest
+++ b/x11-misc/x11vnc/Manifest
@@ -1 +1,2 @@
DIST 82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a.zip 1830730 SHA256 fc6a28df089e47b68931019ce038b6e2fcd78e93de7f6984a22262252d01c16f SHA512 0fa4f7b52442793ec1bd82c74f9d092c69262e4f1fa93584fef17bbe0e5cbde08bc5ad0924631801bb43b41d90c37077a317c61511553f98698096eab05791eb WHIRLPOOL f1a45b549fb6ff9bea2eb4e3719b5dd43a78f6f418c61691cebab313d56761147d928648e103c654309575bec7c716a6f1cd1ef7a9b484c09edee37233cb0ce7
+DIST x11vnc-0.9.13_p20150627.tar.gz 1700142 SHA256 14fb77e9b875224b47fee659d5a883c26c2792c5e37d1e32286b03103fdaef07 SHA512 c28cfe47c1a0bb486bb3290511a8a71cf499e55617e3f488d45cb6a1e9050e4f52c5bb6eb9f2f655728f2028d2472a88d8b9178d59e79c1f07464782555abc82 WHIRLPOOL d0342ef8d948b0dda119967f9e59be6f1e4d2639859f8c2a45c37eeb644e970b322937635f151256b3c30a69d37838f380ab4732c5afd44499e9decb8412aa15
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13_p20150627.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13_p20150627.ebuild
new file mode 100644
index 000000000000..bfe2cb09e4af
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13_p20150627.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="https://libvnc.github.io/"
+SRC_URI="https://github.com/LibVNC/x11vnc/archive/7aba1a36d902ec601e4aae1bc32e957749eb25d3.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon libressl ssl xinerama"
+
+RDEPEND=">=net-libs/libvncserver-0.9.8
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ >=x11-libs/libXtst-1.1.0
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+DOCS=(ChangeLog README)
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with avahi) \
+ $(use_with crypt) \
+ $(use_with fbcon fbdev) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ --without-v4l \
+ $(use_with xinerama)
+}