summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-06-06 16:44:04 +0000
committerFlorian Schmaus <flow@gentoo.org>2024-06-08 09:45:37 +0200
commitb75887764f07fd7d72770ce2166aa0dfcafd4c1e (patch)
tree590c8e18d67b683fef102dfe2bc1f62eb31b5dba /x11-misc/sxcs
parentnet-irc/weechat: add missing dependency with USE=relay-api (diff)
downloadgentoo-b75887764f07fd7d72770ce2166aa0dfcafd4c1e.tar.gz
gentoo-b75887764f07fd7d72770ce2166aa0dfcafd4c1e.tar.bz2
gentoo-b75887764f07fd7d72770ce2166aa0dfcafd4c1e.zip
x11-misc/sxcs: add v1.1.0
Signed-off-by: NRK <nrk@disroot.org> Closes: https://github.com/gentoo/gentoo/pull/37055 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/sxcs')
-rw-r--r--x11-misc/sxcs/Manifest1
-rw-r--r--x11-misc/sxcs/sxcs-1.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/sxcs/Manifest b/x11-misc/sxcs/Manifest
index 3fd636a3a269..4673878991f6 100644
--- a/x11-misc/sxcs/Manifest
+++ b/x11-misc/sxcs/Manifest
@@ -1,2 +1,3 @@
DIST sxcs-0.7.3.tar.gz 22204 BLAKE2B 04bb29188c89622dd2bc348dbc334963a807691ce6fda2f6a6eafedc860be5855d614aeab801dd6cba916dae67a5af92d37317420a04345f1aa8d9203cc44510 SHA512 dbd11ecae74e7a50a346efd0d919952cdd138ebcf75a369888c9f889fcc2752923152b07bcec5f7d4f259672e3af11762d88d9a0b7fe37342f9f5880ecd724ec
DIST sxcs-1.0.0.tar.gz 22787 BLAKE2B 3b36d13ed631c6b7686314f3be7ca4621c88fdf867b0dad02beff815d008fe23e75771f4bdb92a806a93e000d037cae8c12a2315cba74c154e6b94524b3038ae SHA512 dbcd20d894ac2d63f3c93dcee9881a068d40f33cbce5527de746dca2dc34fe264eb91d0849cff81a2730b78645ed421ccf763b544922fbd626361b8056f24d3a
+DIST sxcs-1.1.0.tar.gz 23376 BLAKE2B a843d2b310e0c3ff26ef1767bedd29d863d2f06c53ff8a11934d754b4f76e90546e2298b518ee556ccd8934bfe4a96353a962141a011d96fe76b238b37cae5f0 SHA512 c6e7bf79af3f546950e986838ec4626ce19363f433ae969c7bfdb24d380cf229cad18bd70e6b8ff836fdf44955d604c1119632c641dea8e8f870d42e2602c924
diff --git a/x11-misc/sxcs/sxcs-1.1.0.ebuild b/x11-misc/sxcs/sxcs-1.1.0.ebuild
new file mode 100644
index 000000000000..37f500293aab
--- /dev/null
+++ b/x11-misc/sxcs/sxcs-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo shell-completion toolchain-funcs
+
+DESCRIPTION="Color picker and magnifier for X11"
+HOMEPAGE="https://codeberg.org/NRK/sxcs"
+
+SRC_URI="https://codeberg.org/NRK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcursor
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ edo $(tc-getCC) -o sxcs sxcs.c ${CFLAGS} ${LDFLAGS} -l X11 -l Xcursor
+}
+
+src_install() {
+ dobin sxcs
+ doman sxcs.1
+ dodoc README.md
+ dozshcomp etc/zsh-completion/_sxcs
+}