summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-30 00:15:29 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-30 00:22:14 +0200
commit386f97becb286dada4536bf84d1fead0b40b3f5f (patch)
treebfc24739e601f599ae0360466c520efd9e207919 /x11-misc/sw-notify-send
parentx11-misc/sw-notify-send: Moved back to GitHub (diff)
downloadgentoo-386f97becb286dada4536bf84d1fead0b40b3f5f.tar.gz
gentoo-386f97becb286dada4536bf84d1fead0b40b3f5f.tar.bz2
gentoo-386f97becb286dada4536bf84d1fead0b40b3f5f.zip
x11-misc/sw-notify-send: Modernize to EAPI=6
Diffstat (limited to 'x11-misc/sw-notify-send')
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild12
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-9999.ebuild30
2 files changed, 15 insertions, 27 deletions
diff --git a/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
index 1f96cdc570aa..67c06dc2d15d 100644
--- a/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
+++ b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=5
MY_P=tinynotify-send-${PV}
DESCRIPTION="A system-wide variant of tinynotify-send"
@@ -15,9 +13,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="x11-libs/libtinynotify
+RDEPEND="x11-libs/libtinynotify:0=
~x11-libs/libtinynotify-cli-${PV}
- x11-libs/libtinynotify-systemwide"
+ x11-libs/libtinynotify-systemwide:0="
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -25,11 +23,11 @@ DOCS=( README )
S=${WORKDIR}/${MY_P}
src_configure() {
- myeconfargs=(
+ local myconf=(
--disable-library
--disable-regular
--enable-system-wide
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}
diff --git a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
index f849a3a13dd9..c0ac15bb55ec 100644
--- a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
+++ b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
@@ -3,47 +3,37 @@
EAPI=5
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://github.com/mgorny/tinynotify-send.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils
+inherit autotools git-r3
MY_P=tinynotify-send-${PV}
DESCRIPTION="A system-wide variant of tinynotify-send"
HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
-SRC_URI="https://github.com/mgorny/tinynotify-send/releases/download/${MY_P}/${MY_P}.tar.bz2"
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE=""
RDEPEND="x11-libs/libtinynotify:0=
~x11-libs/libtinynotify-cli-${PV}
x11-libs/libtinynotify-systemwide:0="
DEPEND="${RDEPEND}
+ dev-util/gtk-doc
virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
-
-#if LIVE
-EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
-KEYWORDS=
-SRC_URI=
-DEPEND="${DEPEND}
- dev-util/gtk-doc"
-#endif
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- myeconfargs=(
+ local myconf=(
--disable-library
--disable-regular
--enable-system-wide
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}