summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-07-04 14:53:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-06 01:10:54 +0200
commitfc9a0039eb9b5d4815e10663f30d88a5ab26d412 (patch)
tree517928305eb02c66dbdcb23c7996d7406513e4c5 /x11-misc/shutter
parentkde-plasma/plasma-meta: Fix pkg_postinst exit condition (diff)
downloadgentoo-fc9a0039eb9b5d4815e10663f30d88a5ab26d412.tar.gz
gentoo-fc9a0039eb9b5d4815e10663f30d88a5ab26d412.tar.bz2
gentoo-fc9a0039eb9b5d4815e10663f30d88a5ab26d412.zip
x11-misc/shutter: version 0.94.3_p20200621
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://bugs.gentoo.org/724794 Closes: https://bugs.gentoo.org/728004 Closes: https://github.com/gentoo/gentoo/pull/16585 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/shutter')
-rw-r--r--x11-misc/shutter/Manifest1
-rw-r--r--x11-misc/shutter/shutter-0.94.3_p20200621.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/shutter/Manifest b/x11-misc/shutter/Manifest
index 3f3665f066d3..eb980866b73c 100644
--- a/x11-misc/shutter/Manifest
+++ b/x11-misc/shutter/Manifest
@@ -1 +1,2 @@
DIST shutter-0.94.3.tar.gz 3375447 BLAKE2B e996966722999ee11ed3c185fd17a77e8982688ec17253f3558f89ccfd2e3afefec34d9214acffb10009fc1a28f587a5b994e32d7bb3538cde5e4f398b8e7b95 SHA512 7f67ed6fbc94aee4b6caa73662ab20684e2d8bdfd7208dcd407bdce4e1b93f2aa1fa256ad6bce66b92c741500726b90e5701e7f31bc831709568e5c4c27bff3b
+DIST shutter-0.94.3_p20200621.tar.gz 2571420 BLAKE2B 0567d03d1b511f3bbe889ad6dda3bfa347dc69d96c7ab89368e6e97925d8d4cccb378ee0da179a65a482e6d22117aaff390088e7cac5d695edd3b8fee7c6a396 SHA512 3426b1cc475356cbcbcaba89e59e904907d61ceafb96b7d7994ff3d9a1fcb1f8151099a2361cd8de63b16fe02c1246f0cb50fb7166d666bc502f18e6fdda6d5f
diff --git a/x11-misc/shutter/shutter-0.94.3_p20200621.ebuild b/x11-misc/shutter/shutter-0.94.3_p20200621.ebuild
new file mode 100644
index 000000000000..b29843d0ea8a
--- /dev/null
+++ b/x11-misc/shutter/shutter-0.94.3_p20200621.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+DESCRIPTION="Feature-rich screenshot program"
+HOMEPAGE="https://shutter-project.org/"
+MY_COMMIT="af237e7f415a5fa20402703490c6190dc1af9b20"
+SRC_URI="https://github.com/shutter-project/shutter/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/gnome2-canvas
+ dev-perl/gnome2-wnck
+ dev-perl/libxml-perl
+ dev-perl/libwww-perl
+ dev-perl/Glib-Object-Introspection
+ dev-perl/Gtk2-Unique
+ dev-perl/Gtk2-ImageView
+ dev-perl/File-DesktopEntry
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/JSON
+ dev-perl/File-Copy-Recursive
+ dev-perl/File-MimeInfo
+ dev-perl/Locale-gettext
+ dev-perl/Net-DBus
+ dev-perl/Number-Bytes-Human
+ dev-perl/Proc-Simple
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/WWW-Mechanize
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ virtual/imagemagick-tools[perl]
+"
+
+src_install() {
+ dobin bin/shutter
+ dodoc README
+ domenu share/applications/shutter.desktop
+ doicon share/pixmaps/shutter.png
+
+ # Man page is broken. Reconstruct it.
+ gunzip share/man/man1/shutter.1.gz || die "gunzip failed"
+ doman share/man/man1/shutter.1
+
+ insinto /usr/share
+ doins -r share/shutter
+ doins -r share/locale
+ doins -r share/icons
+
+ insinto /usr/share/metainfo
+ doins share/appdata/shutter.appdata.xml
+
+ # .po doesn't belong to installed system, only .mo
+ rm -r "${ED}"/usr/share/shutter/resources/po || die
+
+ find "${ED}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
+ || die "failed to make plugins executables"
+ # shutter executes perl scripts as standalone scripts, and after that "require"s them.
+ find "${ED}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
+ -name "*.pm" -exec chmod 755 {} \; || die "failed to make upload plugins executables"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ optfeature "writing Exif information" media-libs/exiftool
+ optfeature "drawing tool" dev-perl/Goo-Canvas
+ optfeature "image hostings uploading" "dev-perl/JSON-MaybeXS dev-perl/Net-OAuth dev-perl/Path-Class"
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}