summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-12-02 18:51:23 +0100
committerPacho Ramos <pacho@gentoo.org>2021-12-02 18:51:52 +0100
commitb04653885e55cdbd0ce0d21efdd8dd8410d8396f (patch)
treeae59ab42952c374bde3f59acb482123349f22cc5 /x11-misc/meteo
parentsys-fs/lxcfs: drop 4.0.9 (diff)
downloadgentoo-b04653885e55cdbd0ce0d21efdd8dd8410d8396f.tar.gz
gentoo-b04653885e55cdbd0ce0d21efdd8dd8410d8396f.tar.bz2
gentoo-b04653885e55cdbd0ce0d21efdd8dd8410d8396f.zip
x11-misc/meteo: New app
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc/meteo')
-rw-r--r--x11-misc/meteo/Manifest1
-rw-r--r--x11-misc/meteo/metadata.xml8
-rw-r--r--x11-misc/meteo/meteo-0.9.9.1.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/meteo/Manifest b/x11-misc/meteo/Manifest
new file mode 100644
index 000000000000..f6ed738831ff
--- /dev/null
+++ b/x11-misc/meteo/Manifest
@@ -0,0 +1 @@
+DIST meteo-0.9.9.1.tar.gz 598205 BLAKE2B ac66e84a04f087cf75f9101da0c80e68c132e0e5064aec4cb2ea609e93f48a2ef3eb51266805b2547b4839c82496b470d4bb07e4fa0538e2ebc691a9491606d8 SHA512 d148393acc47dab1886a25600adb2a3e2ff5cb313c0004d50a54106c61f3cbd26ff95d526d13a77a1d33ede2622ff2ea9277a8fdc1899ebf34581a5a6b36c861
diff --git a/x11-misc/meteo/metadata.xml b/x11-misc/meteo/metadata.xml
new file mode 100644
index 000000000000..424492050f4c
--- /dev/null
+++ b/x11-misc/meteo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/meteo/meteo-0.9.9.1.ebuild b/x11-misc/meteo/meteo-0.9.9.1.ebuild
new file mode 100644
index 000000000000..13bc758b8d46
--- /dev/null
+++ b/x11-misc/meteo/meteo-0.9.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Forecast application using OpenWeatherMap API"
+HOMEPAGE="https://gitlab.com/bitseater/meteo"
+SRC_URI="https://gitlab.com/bitseater/meteo/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/libappindicator:3
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/hicolor-icon-theme
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ dosym com.gitlab.bitseater.meteo /usr/bin/meteo
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}