summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-19 14:11:35 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-19 14:11:35 +0200
commit61067a21c1ccfba0b6be60a035bcc4c31cbb1389 (patch)
tree65d0009424c4c4312d090b76bd9768fe3162f504 /x11-misc/gigolo
parentwww-client/vivaldi-snapshot: Old (diff)
downloadgentoo-61067a21c1ccfba0b6be60a035bcc4c31cbb1389.tar.gz
gentoo-61067a21c1ccfba0b6be60a035bcc4c31cbb1389.tar.bz2
gentoo-61067a21c1ccfba0b6be60a035bcc4c31cbb1389.zip
x11-misc/gigolo: Replace gvfs-open with 'gio open' in defaults
Closes: https://bugs.gentoo.org/688022 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-misc/gigolo')
-rw-r--r--x11-misc/gigolo/gigolo-0.4.91-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/gigolo/gigolo-0.4.91-r1.ebuild b/x11-misc/gigolo/gigolo-0.4.91-r1.ebuild
new file mode 100644
index 000000000000..8a8013bbe625
--- /dev/null
+++ b/x11-misc/gigolo/gigolo-0.4.91-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="https://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-3.14:3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm COPYING || die
+ # https://git.xfce.org/apps/gigolo/commit/?id=fb63ddf0fa4ed93789366aefb7a2a2b44e919386
+ sed -i -e 's:gvfs-open:gio open:' src/settings.c || die
+ default
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}