summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/chgres
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/chgres')
-rw-r--r--x11-misc/chgres/Manifest1
-rw-r--r--x11-misc/chgres/chgres-0.1-r1.ebuild34
-rw-r--r--x11-misc/chgres/files/chgres-0.1-flags.patch21
-rw-r--r--x11-misc/chgres/files/chgres-0.1-includes.patch15
-rw-r--r--x11-misc/chgres/metadata.xml6
5 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/chgres/Manifest b/x11-misc/chgres/Manifest
new file mode 100644
index 000000000000..c752d7a362c7
--- /dev/null
+++ b/x11-misc/chgres/Manifest
@@ -0,0 +1 @@
+DIST chgres-0.1.tar.gz 9219 RMD160 dff610b2c712f20fe7f3bd54c7d2a14083041532 SHA1 1ad31364d62df383198fc1f01a1c923a7059fdd1 SHA256 37f76425c92c5cf8d2448c87886474348d1a05ead1ac085aa885c2533c5efb26
diff --git a/x11-misc/chgres/chgres-0.1-r1.ebuild b/x11-misc/chgres/chgres-0.1-r1.ebuild
new file mode 100644
index 000000000000..75f47747139c
--- /dev/null
+++ b/x11-misc/chgres/chgres-0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A very simple command line utility for changing X resolutions"
+HOMEPAGE="http://hpwww.ec-lyon.fr/~vincent/"
+SRC_URI="http://hpwww.ec-lyon.fr/~vincent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXxf86dga
+ x11-libs/libXext
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{flags,includes}.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin chgres
+ dodoc README
+}
diff --git a/x11-misc/chgres/files/chgres-0.1-flags.patch b/x11-misc/chgres/files/chgres-0.1-flags.patch
new file mode 100644
index 000000000000..4045175dde09
--- /dev/null
+++ b/x11-misc/chgres/files/chgres-0.1-flags.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2001-04-18 23:07:56.000000000 +0200
++++ b/Makefile 2010-09-17 03:08:55.000000000 +0200
+@@ -1,9 +1,9 @@
+-CFLAGS=
+-LDFLAGS= -L/usr/X11R6/lib -lXext -lX11 -lXxf86vm -lXxf86dga
++LIBS= $(shell pkg-config --libs xext x11 xxf86vm xxf86dga)
++INCLUDES= $(shell pkg-config --cflags xext x11 xxf86vm xxf86dga)
+ prefix=/usr
+
+ chgres: chgres.o
+- $(CC) -o $@ $< $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ install: chgres
+ install -D -m 0555 chgres $(prefix)/bin/
+@@ -12,4 +12,4 @@
+ rm -f core chgres.o chgres
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
diff --git a/x11-misc/chgres/files/chgres-0.1-includes.patch b/x11-misc/chgres/files/chgres-0.1-includes.patch
new file mode 100644
index 000000000000..c972ab96fc8f
--- /dev/null
+++ b/x11-misc/chgres/files/chgres-0.1-includes.patch
@@ -0,0 +1,15 @@
+--- a/chgres.c 2001-04-18 22:40:05.000000000 +0200
++++ b/chgres.c 2010-09-17 03:20:37.000000000 +0200
+@@ -17,9 +17,11 @@
+ */
+
+ #include <X11/Xlib.h>
+-#include <X11/extensions/xf86dga.h>
++#include <X11/extensions/Xxf86dga.h>
+ #include <X11/extensions/xf86vmode.h>
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
++#include <strings.h> /* strcasecmp() */
+
+ #define VERSION "0.1"
+
diff --git a/x11-misc/chgres/metadata.xml b/x11-misc/chgres/metadata.xml
new file mode 100644
index 000000000000..170550f4616e
--- /dev/null
+++ b/x11-misc/chgres/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription>chgres is a small tool which uses the XFree86-VidModeExtension X11 extension to query and set the resolution of your XFree86 display, without restarting it. It has a simple command-line user interface which makes it suitable for use in shell scripts.</longdescription>
+</pkgmetadata>