summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Mróz <mrozigor@wp.pl>2018-11-01 17:49:11 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-11-17 18:20:23 +0100
commitbfe93126cae07d58f4e71cb9528793522067639b (patch)
tree6e0daa625add59a6a8c70dd1551bee68f625c23a /x11-libs
parentdev-lang/spidermonkey: fix bitness on alpha (diff)
downloadgentoo-bfe93126cae07d58f4e71cb9528793522067639b.tar.gz
gentoo-bfe93126cae07d58f4e71cb9528793522067639b.tar.bz2
gentoo-bfe93126cae07d58f4e71cb9528793522067639b.zip
x11-libs/goffice: bump to 0.10.43
Signed-off-by: Igor Mróz <mrozigor@wp.pl> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10317 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.43.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 9d4340b08d11..2d5a94d8a320 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,2 +1,3 @@
DIST goffice-0.10.38.tar.xz 2373308 BLAKE2B f270233adbbf300ad41516b1ed988db0772b95940196a6ac92c3090f6e52bc47933bb6bb4c023d7137cbca42adfab17fc41b82042c2e9c0340a6cd84942874e5 SHA512 1d72e30ee0b9f322cd4114d0a024a99e6d9ff7efcaeb9ca40b5fffe94180c232f03935743c15b1c6170f8bfc04fea5bdcc4d12760643c66cffafefbaa562fd62
DIST goffice-0.10.41.tar.xz 2381656 BLAKE2B 7d73b892d91f917e3a47058f508094a16bb50860686dcf33c68ac8028b40e7ba74cc276f276672f29ddafef73b03887cf6280a2812305bd9b24ae3021c319d25 SHA512 d4b6a30b2b5d92e7500a1810626d20a2d4e5f66c1a879c904fe57df384bf4a480de322e9ae0a5fe7a44e73e060d9a33da6d56cd051c3d6cb1ebf0eae09fda2f8
+DIST goffice-0.10.43.tar.xz 2381804 BLAKE2B 60e305620118f80595a0dfec8192648273f845c9f868142adb957796ee291e1e53b0f3d3f2446064d8014ec54e7008ac03eca7f2f4925efa00ff42b98810371b SHA512 979ccf67fe08d09a2cf0413b4674a44208aa5f4802ab086a463ea2b449fc8c9d1c96dea7234c8e715064cf1726a47d2a5428728a2ff0d00759d5fe7017dc709f
diff --git a/x11-libs/goffice/goffice-0.10.43.ebuild b/x11-libs/goffice/goffice-0.10.43.ebuild
new file mode 100644
index 000000000000..6101179ce7e1
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.43.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+SRC_URI="https://ftp.gnome.org/pub/GNOME/sources/goffice/0.10/goffice-0.10.43.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}