summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Tambet <ttambet@gmail.com>2017-02-24 21:07:42 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-24 23:55:14 +0200
commit855f0e3520aadd2f3584a3dcf9d3559ee5a429dd (patch)
tree66e7a59923f6d5a06bde29b331fbdb53c0ba048d /x11-libs
parentnet-misc/dhcpcd: Change live ebuild to pull from git per upstream request (diff)
downloadgentoo-855f0e3520aadd2f3584a3dcf9d3559ee5a429dd.tar.gz
gentoo-855f0e3520aadd2f3584a3dcf9d3559ee5a429dd.tar.bz2
gentoo-855f0e3520aadd2f3584a3dcf9d3559ee5a429dd.zip
x11-libs/gdk-pixbuf: bump to 2.36.5
Reviewed-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/Manifest1
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.5.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf/Manifest b/x11-libs/gdk-pixbuf/Manifest
index 46964d6b5975..270cbdfc87de 100644
--- a/x11-libs/gdk-pixbuf/Manifest
+++ b/x11-libs/gdk-pixbuf/Manifest
@@ -1,2 +1,3 @@
DIST gdk-pixbuf-2.34.0.tar.xz 2709320 SHA256 d55e5b383ee219bd0e23bf6ed4427d56a7db5379729a6e3e0a0e0eba9a8d8879 SHA512 874aed9af0352592674f2bebd4d9b0a945932a410c9f0b776f45766c2f18d442a39c684cca69b1aca6d14f67f18e690489f388ff58699dbd0efbd13244a1a8b5 WHIRLPOOL c2f7b1ac0d2fa13a00c1bed37a66b9b13564e1cef5262db656c640b0256f821658f8e6d0e1e5a300a2af83847b15518d7e0c72995df877970bf44ad28e5fd416
DIST gdk-pixbuf-2.36.2.tar.xz 4877452 SHA256 3a082ad67d68b55970aed0b2034a06618167be98a42d5c70de736756b45d325d SHA512 34a569aee7a26af701edbc9bf895617dc59d1a7f98292c832885cff88733cb7f581253a5caeecf265712a07f975b7c7dfeda4050e7a81cb5c9de19b4b82d17ba WHIRLPOOL fb2871f32084a2c40cea9cd662167645d5458dd4b96faa9967356a5a95b3a173f8d54c41608dfae0344460ffd87441be0f3c465eef7dbae979e5c2d8fb92ff27
+DIST gdk-pixbuf-2.36.5.tar.xz 5165640 SHA256 7ace06170291a1f21771552768bace072ecdea9bd4a02f7658939b9a314c40fc SHA512 27c39bace7bc6cf713915dcb1f35eebfb80ae599d1c9106f48af4cd447050c41e37adee76d29d6b42fbe3d0123b054c8701f2d1b4b99060b4869aa7871523b70 WHIRLPOOL 3ffdf7b50733425750eb327409f538541e7f8758b614c9b4fd62507508eeb934e2644e9da5be44a3900034fcdda624cb20786950729f3ca199fd27b0cd8cddd4
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.5.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.5.ebuild
new file mode 100644
index 000000000000..d893165526cf
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.5.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils flag-o-matic gnome2 multilib libtool multilib-minimal
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="https://git.gnome.org/browse/gdk-pixbuf"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="X debug +introspection jpeg jpeg2k tiff test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.48.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+ jpeg2k? ( media-libs/jasper:=[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.2:0=[${MULTILIB_USEDEP}] )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig
+"
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<gnome-base/librsvg-2.31.0
+ !<x11-libs/gtk+-2.21.3:2
+ !<x11-libs/gtk+-2.90.4:3
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gdk-pixbuf-query-loaders$(get_exeext)
+)
+
+src_prepare() {
+ # See https://bugzilla.gnome.org/show_bug.cgi?id=756590
+ eapply "${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
+
+ # This will avoid polluting the pkg-config file with versioned libpng,
+ # which is causing problems with libpng14 -> libpng15 upgrade
+ # See upstream bug #667068
+ # First check that the pattern is present, to catch upstream changes on bumps,
+ # because sed doesn't return failure code if it doesn't do any replacements
+ grep -q 'l in libpng16' configure || die "libpng check order has changed upstream"
+ sed -e 's:l in libpng16:l in libpng libpng16:' -i configure || die
+ [[ ${CHOST} == *-solaris* ]] && append-libs intl
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # png always on to display icons
+ ECONF_SOURCE="${S}" \
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes "") \
+ $(use_with jpeg libjpeg) \
+ $(use_with jpeg2k libjasper) \
+ $(use_with tiff libtiff) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with X x11) \
+ --with-libpng
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/${PN}/html docs/reference/${PN}/html || die
+ fi
+}
+
+multilib_src_install() {
+ # Parallel install fails when no gdk-pixbuf is already installed, bug #481372
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+
+ multilib_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ multilib_foreach_abi gnome2_pkg_postinst
+
+ # Migration snippet for when this was handled by gtk+
+ if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ rm -f "${EROOT}"usr/lib*/${PN}-2.0/2.10.0/loaders.cache
+ fi
+}