summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-12-21 22:59:41 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-04 23:37:22 +0100
commit7aa70f171498938a4e36630a37f6d300f8c0459c (patch)
tree3b0b28c57f7432cf70b5257bd82351435064aaba /x11-libs
parentapp-misc/gnote: bump to 3.22.1 (diff)
downloadgentoo-7aa70f171498938a4e36630a37f6d300f8c0459c.tar.gz
gentoo-7aa70f171498938a4e36630a37f6d300f8c0459c.tar.bz2
gentoo-7aa70f171498938a4e36630a37f6d300f8c0459c.zip
x11-libs/gtksourceview: bump to 3.22.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3208 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.22.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index 7b709560e972..962096bc65c9 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -3,3 +3,4 @@ DIST gtksourceview-3.16.1.tar.xz 1272152 SHA256 669e9846ca744ec4d04ce61377e85df7
DIST gtksourceview-3.18.2.tar.xz 1317804 SHA256 60f75a9f0039e13a2281fc595b5ef7344afa06732cc53b57d13234bfb0a5b7b2 SHA512 75e502264d7d9f63f9a2c9c884072cfc2d323c7cc49383b9b53916321ce20ef695e7a2dd0f6db67a4daf70ba84a3a907dfc6d9407ba5982adb976210e0589328 WHIRLPOOL 4143a624a0582a5d92de707b5167bc9805a5b484906977c4b0d195703d7bd113ebd677829f6e6c2c2d8d10cdae2041db99e8294e18e7114d53e15da6f233ad80
DIST gtksourceview-3.20.4.tar.xz 1582240 SHA256 7a0e6ac95ff3862bd8ef77a40e95a942939e73cb407f2eb67af600d7ce533d01 SHA512 4b69759e77acd120da24683e9cacd994e5bcef4c7b6404bad2df930b228a39f99f9391e137583fadb4939189f66f088bd386192b4d23bc232d718804156db941 WHIRLPOOL 7fb3895b3eeb56375ead63b709d4e0b0b02a33fdfed745a9a714af2e72f80c548228201702d317519cc0fb655c8c2e39c60333275889d323a59efb22556b28a1
DIST gtksourceview-3.22.1.tar.xz 1596868 SHA256 a05b3f8bc866db4abad16528fc166ee31e9a2c90a933a99476bc474086a3b6af SHA512 98d9396f98e2f3f0e20d10b37a0d32fa4147ae442e39146829d56d17886df4519676483d4d862afae317b9cb79fdde1f4c95eff34224291a569207cd2febcea4 WHIRLPOOL 461bd4f2267390c32c2be45e53312eb24e04fe0474ee44f9157f6f921aa80e0179115b1ab365c4ea936602aec03a0c903d24e7004e497d1ce9e75587934e3474
+DIST gtksourceview-3.22.2.tar.xz 1596384 SHA256 6ce84231dd0931cc747708434ca2f344c65a092dd6e1a800283fe0748773af5e SHA512 1d51a975471172835cd9af64828ba93eb1b45e26fae91b1778c5963a8578404bbbdf1fe7f2c92953dff436bf2dac2d9e01a5188216d2a60a705e4635f0c91b81 WHIRLPOOL 76f333a55d868f6e56bdf8ead44b541c78083a5a64d5b19ae2423a9b22cb8cf17e2fe063dd1a569baab192597c34dde42c6f104c27c13d40b364a81f71e8a183
diff --git a/x11-libs/gtksourceview/gtksourceview-3.22.2.ebuild b/x11-libs/gtksourceview/gtksourceview-3.22.2.ebuild
new file mode 100644
index 000000000000..9b2b0026c66b
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.22.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ dev-util/itstool
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}