summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-28 22:40:16 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-28 22:40:25 +0100
commit7a23b9bba3f0e68881bdd660553ac860cef5d005 (patch)
treeeff5bdb3caee9e52edb2da90c6afdd7fd277cd11 /x11-libs
parentdev-lang/php: stable 7.1.26 for hppa, bug #675182 (diff)
downloadgentoo-7a23b9bba3f0e68881bdd660553ac860cef5d005.tar.gz
gentoo-7a23b9bba3f0e68881bdd660553ac860cef5d005.tar.bz2
gentoo-7a23b9bba3f0e68881bdd660553ac860cef5d005.zip
x11-libs/libvdpau: Version 1.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libvdpau/Manifest1
-rw-r--r--x11-libs/libvdpau/libvdpau-1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/libvdpau/Manifest b/x11-libs/libvdpau/Manifest
index 349ebbbc5bd8..2dfe563abd99 100644
--- a/x11-libs/libvdpau/Manifest
+++ b/x11-libs/libvdpau/Manifest
@@ -1 +1,2 @@
DIST libvdpau-1.1.1.tar.gz 541752 BLAKE2B 346dad1ee83193fb489a67016874b1cb9eccc88833766f1df987ed7369078cf259c168546d64ab847d81baceb4e4969d859c29a4081befbe100925d457dfb6df SHA512 e094494fc820c2395c9dbb4e69daa89334b9186e2ad1a6c06671c7f844568db191ce4d1d9df95c4536579864bcc8541eb6fd159c377bc73c228cdf2a0fea50fb
+DIST libvdpau-libvdpau-1.2.tar.bz2 140017 BLAKE2B 0420961c48fcd5c92e7e98f84f629946f6234c28781bd7d8c9eb4aa2ab11b76e89e05f50cc423a2935b3376ff3b919ad9e6ef1710ff3549369567f298b5efa50 SHA512 f76c2283a1bd2e854aa6b86a564f7f08c1ff7da34e971c7c39f36e77fbd51fe0440d1ba01bff0b80be6c0326817ee4e6bff719dbe8dbf5e1ec7a94fad5016b7e
diff --git a/x11-libs/libvdpau/libvdpau-1.2.ebuild b/x11-libs/libvdpau/libvdpau-1.2.ebuild
new file mode 100644
index 000000000000..b0205ff82448
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VIRTUALX_REQUIRED="test"
+inherit autotools flag-o-matic virtualx multilib-minimal
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/${PN}/-/archive/${P}/${PN}-${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ dri? ( >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( x11-base/xorg-proto )
+"
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ append-cppflags -D_GNU_SOURCE
+ econf \
+ $(use dri || echo --disable-dri2) \
+ $(use_enable doc documentation) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+multilib_src_test() {
+ virtx emake check
+}