summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-09-12 14:25:46 -0400
committerMatt Turner <mattst88@gentoo.org>2024-09-12 15:02:09 -0400
commit3a9bc2c57733e0fd19f4414deb2122605819c311 (patch)
tree9971c9b7d81ee33fa900b2aa03c3fde8f0ecedc9 /x11-libs
parentsys-devel/crossdev: Stabilize 20240702 ppc64, #939148 (diff)
downloadgentoo-3a9bc2c57733e0fd19f4414deb2122605819c311.tar.gz
gentoo-3a9bc2c57733e0fd19f4414deb2122605819c311.tar.bz2
gentoo-3a9bc2c57733e0fd19f4414deb2122605819c311.zip
x11-libs/libdrm: Add IUSE=doc to control man pages
The man pages are just man3 and man7, so unlikely to be used. Avoids a circular dependency as well: (x11-libs/libdrm-2.4.122:0/0::gentoo, ebuild scheduled for merge) depends on (dev-python/docutils-0.21.2-1:0/0::gentoo, binary scheduled for merge) (buildtime) (dev-python/pillow-10.4.0:0/0::gentoo, ebuild scheduled for merge) (runtime) (media-libs/libwebp-1.3.2:0/7::gentoo, ebuild scheduled for merge) (buildtime_slot_op) (virtual/opengl-7.0-r2:0/0::gentoo, ebuild scheduled for merge) (buildtime) (media-libs/mesa-24.1.6:0/0::gentoo, ebuild scheduled for merge) (runtime) (x11-libs/libdrm-2.4.122:0/0::gentoo, ebuild scheduled for merge) (buildtime) Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm/libdrm-2.4.122-r1.ebuild (renamed from x11-libs/libdrm/libdrm-2.4.122.ebuild)6
-rw-r--r--x11-libs/libdrm/libdrm-2.4.123-r1.ebuild (renamed from x11-libs/libdrm/libdrm-2.4.123.ebuild)6
-rw-r--r--x11-libs/libdrm/libdrm-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/x11-libs/libdrm/libdrm-2.4.122.ebuild b/x11-libs/libdrm/libdrm-2.4.122-r1.ebuild
index fa39ce92defa..f2fe1b0a540a 100644
--- a/x11-libs/libdrm/libdrm-2.4.122.ebuild
+++ b/x11-libs/libdrm/libdrm-2.4.122-r1.ebuild
@@ -26,7 +26,7 @@ done
LICENSE="MIT"
SLOT="0"
-IUSE="${IUSE_VIDEO_CARDS} test tools udev valgrind"
+IUSE="${IUSE_VIDEO_CARDS} doc test tools udev valgrind"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -40,9 +40,10 @@ RDEPEND="${COMMON_DEPEND}
)
udev? ( virtual/udev )"
BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+ doc? ( $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]') )"
python_check_deps() {
+ use doc || return 0
python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
}
@@ -70,6 +71,7 @@ multilib_src_configure() {
# valgrind installs its .pc file to the pkgconfig for the primary arch
-Dvalgrind=$(usex valgrind auto disabled)
$(meson_native_use_bool tools install-test-programs)
+ $(meson_native_use_feature doc man-pages)
)
if use test || { multilib_is_native_abi && use tools; }; then
diff --git a/x11-libs/libdrm/libdrm-2.4.123.ebuild b/x11-libs/libdrm/libdrm-2.4.123-r1.ebuild
index 389ed76260af..25b11549579e 100644
--- a/x11-libs/libdrm/libdrm-2.4.123.ebuild
+++ b/x11-libs/libdrm/libdrm-2.4.123-r1.ebuild
@@ -26,7 +26,7 @@ done
LICENSE="MIT"
SLOT="0"
-IUSE="${IUSE_VIDEO_CARDS} test tools udev valgrind"
+IUSE="${IUSE_VIDEO_CARDS} doc test tools udev valgrind"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -40,9 +40,10 @@ RDEPEND="${COMMON_DEPEND}
)
udev? ( virtual/udev )"
BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+ doc? ( $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]') )"
python_check_deps() {
+ use doc || return 0
python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
}
@@ -70,6 +71,7 @@ multilib_src_configure() {
# valgrind installs its .pc file to the pkgconfig for the primary arch
-Dvalgrind=$(usex valgrind auto disabled)
$(meson_native_use_bool tools install-test-programs)
+ $(meson_native_use_feature doc man-pages)
)
if use test || { multilib_is_native_abi && use tools; }; then
diff --git a/x11-libs/libdrm/libdrm-9999.ebuild b/x11-libs/libdrm/libdrm-9999.ebuild
index 389ed76260af..25b11549579e 100644
--- a/x11-libs/libdrm/libdrm-9999.ebuild
+++ b/x11-libs/libdrm/libdrm-9999.ebuild
@@ -26,7 +26,7 @@ done
LICENSE="MIT"
SLOT="0"
-IUSE="${IUSE_VIDEO_CARDS} test tools udev valgrind"
+IUSE="${IUSE_VIDEO_CARDS} doc test tools udev valgrind"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -40,9 +40,10 @@ RDEPEND="${COMMON_DEPEND}
)
udev? ( virtual/udev )"
BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+ doc? ( $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]') )"
python_check_deps() {
+ use doc || return 0
python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
}
@@ -70,6 +71,7 @@ multilib_src_configure() {
# valgrind installs its .pc file to the pkgconfig for the primary arch
-Dvalgrind=$(usex valgrind auto disabled)
$(meson_native_use_bool tools install-test-programs)
+ $(meson_native_use_feature doc man-pages)
)
if use test || { multilib_is_native_abi && use tools; }; then