summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/xforms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/xforms')
-rw-r--r--x11-libs/xforms/Manifest1
-rw-r--r--x11-libs/xforms/metadata.xml7
-rw-r--r--x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild47
3 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/xforms/Manifest b/x11-libs/xforms/Manifest
new file mode 100644
index 000000000000..86b23e4dc54d
--- /dev/null
+++ b/x11-libs/xforms/Manifest
@@ -0,0 +1 @@
+DIST xforms-1.0.93sp1.tar.gz 2204088 SHA256 0cbef8c16c478b7fc87cf24be618114f9b7d14dc0a06b61a352bb027dd3b2ca4 SHA512 b352b345f110966741f82645f1282805dd27e4eb16642efedb4f7e0132a109f525da678052b501d1d520014bb7f754f5b53676a83cfab5a249c02db835c66a6a WHIRLPOOL e5d83d3aef7bc06612afa6a64f01bbc101c796ae4baf65198088627fcf9e241285707cf9d92b01927fe5970cc8c0e1f1ceb829037c224e0fbb37f41b4997ab54
diff --git a/x11-libs/xforms/metadata.xml b/x11-libs/xforms/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/x11-libs/xforms/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild b/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild
new file mode 100644
index 000000000000..1249a491816b
--- /dev/null
+++ b/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P="${P/_/s}"
+
+DESCRIPTION="A graphical user interface toolkit for X"
+HOMEPAGE="http://www.nongnu.org/xforms/"
+SRC_URI="http://savannah.nongnu.org/download/xforms/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="doc opengl static-libs"
+
+RDEPEND="virtual/jpeg
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog NEWS README )
+
+src_prepare() {
+ rm "${S}"/config/libtool.m4 "${S}"/acinclude.m4
+ AT_M4DIR=config eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable opengl gl) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}