summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-19 15:09:40 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-19 15:09:43 -0700
commitbe8a46fa13505e6cc7d3aa10c19cac5429db3812 (patch)
treed699b8e5d9c0d4acb3feaa13d71a3fab3d381682 /x11-libs/pixman
parentx11-libs/pixman: Reintroduce static-libs USE flag (diff)
downloadgentoo-be8a46fa13505e6cc7d3aa10c19cac5429db3812.tar.gz
gentoo-be8a46fa13505e6cc7d3aa10c19cac5429db3812.tar.bz2
gentoo-be8a46fa13505e6cc7d3aa10c19cac5429db3812.zip
x11-libs/pixman: Version bump to 0.40.0
Closes https://bugs.gentoo.org/694094 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.40.0.ebuild59
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild2
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index 6acf91b88842..3ce2039a5fe9 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1 +1,2 @@
DIST pixman-0.38.4.tar.gz 897926 BLAKE2B 2c27069411e709391a1cc0af6c37acf2f06b4fad433a3197e24a0636d5d828ddbf1ca339d91470514d75e126452bc2300d14a2b862671bd11a8b85057d86b31c SHA512 b66dc23c0bc7327cb90085cbc14ccf96ad58001a927f23af24e0258ca13f32d4255535862f1efcf00e9e723410aa9f51edf26fb01c8cde49379d1225acf7b5af
+DIST pixman-0.40.0.tar.xz 634752 BLAKE2B 29b71f5eb6c3df0318c7a6153c6abbce29748b0b578697916414a869a029635fe5e0bab06b8f701a764c95e475c115ed12eb4f93c751d234b5868f4c4196d7db SHA512 8a60edb113d68791b41bd90b761ff7b3934260cb3dada3234c9351416f61394e4157353bc4d61b8f6c2c619de470f6feefffb4935bfcf79d291ece6285de7270
diff --git a/x11-libs/pixman/pixman-0.40.0.ebuild b/x11-libs/pixman/pixman-0.40.0.ebuild
new file mode 100644
index 000000000000..9c15b1e09657
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.40.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs"
+
+multilib_src_configure() {
+ local openmp=disabled
+ tc-has-openmp && openmp=enabled
+
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature cpu_flags_ppc_altivec vmx)
+ $(meson_feature cpu_flags_arm_neon neon)
+ $(meson_feature loongson2f loongson-mmi)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ -Dopenmp=$openmp # only used in unit tests
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
+ meson test -v -C "${BUILD_DIR}" -t 100
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index 296db0dbcb16..9c15b1e09657 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -17,7 +17,7 @@ if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
- SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.gz"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
fi
LICENSE="MIT"