summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-21 03:55:44 +0000
committerSam James <sam@gentoo.org>2023-01-21 03:56:11 +0000
commit5b86df4fdf4c864e1023f60e838f194c42fadfa2 (patch)
treea6791ef8563f6c8cb1ad1cccdd315559a2b36adb /x11-libs/pixman
parentdev-util/hip: append -fno-stack-protector for hipcc (diff)
downloadgentoo-5b86df4fdf4c864e1023f60e838f194c42fadfa2.tar.gz
gentoo-5b86df4fdf4c864e1023f60e838f194c42fadfa2.tar.bz2
gentoo-5b86df4fdf4c864e1023f60e838f194c42fadfa2.zip
x11-libs/pixman: fix build for arm64
Closes: https://bugs.gentoo.org/891459 Bug: https://bugs.gentoo.org/768138 See: 18745f353da4ddd132b344f0f20e035dfa917b93 Thanks-to: Fergus Dall <sidereal@google.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/pixman-0.42.2.ebuild4
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-libs/pixman/pixman-0.42.2.ebuild b/x11-libs/pixman/pixman-0.42.2.ebuild
index a374ef666c6d..2e5fa64a855c 100644
--- a/x11-libs/pixman/pixman-0.42.2.ebuild
+++ b/x11-libs/pixman/pixman-0.42.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,7 +34,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use arm && tc-is-clang ; then
+ if ( use arm || use arm64 ) && tc-is-clang ; then
# See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
append-cflags $(test-flags-CC -fno-integrated-as)
fi
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index 1cd3dd3a43a8..e4c0e9e9a0ee 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,7 +34,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use arm && tc-is-clang ; then
+ if ( use arm || use arm64 ) && tc-is-clang ; then
# See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
append-cflags $(test-flags-CC -fno-integrated-as)
fi