summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-12 15:40:07 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-12 16:54:02 -0700
commitca3090608d19325d661cd5adcc0bacae1f27e631 (patch)
tree0d708f948297b06664d1d5fa3c53a59468d29cfe /x11-base
parentx11-base/xwayland: Port to EAPI=8 (diff)
downloadgentoo-ca3090608d19325d661cd5adcc0bacae1f27e631.tar.gz
gentoo-ca3090608d19325d661cd5adcc0bacae1f27e631.tar.bz2
gentoo-ca3090608d19325d661cd5adcc0bacae1f27e631.zip
x11-base/xwayland: Version bump to 22.1.3
Bug: https://bugs.gentoo.org/857780 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-22.1.3.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 2676b3b27849..ae3af87e0723 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1 +1,2 @@
DIST xwayland-22.1.2.tar.xz 1271848 BLAKE2B 2efb3111396e1ed6ae6a4489c6d8612d511daea95edf456e60136185db9a69f937f0ab838e3c3095b76f9221d3b84ec0a1a7424f849e69d26eada0b988ebb675 SHA512 c8620169f16c2bbd592dbe77bc1f7a2c27a78f49a89bf966d8a449b7faacd69f5ea4aac7adb5b75e06dcc5efca26a2141c9b5d4cf6a592ec7882bad5e235bce4
+DIST xwayland-22.1.3.tar.xz 1272440 BLAKE2B 5f35d6675ee90d910ed39921b4590e7a5325f941238c69b09d6b7063bcded992d1e4425327ae4626e8e9cead7dc17b4d892642a1a3bdb3a4de797f8f733202c4 SHA512 be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4
diff --git a/x11-base/xwayland/xwayland-22.1.3.ebuild b/x11-base/xwayland/xwayland-22.1.3.ebuild
new file mode 100644
index 000000000000..384312c2aa5c
--- /dev/null
+++ b/x11-base/xwayland/xwayland-22.1.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.20
+ >=dev-libs/wayland-protocols-1.22
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}