summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-09 22:40:01 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-09 23:29:17 +0200
commitbf02dbae72b37faec40e8c42f62f952cd47133ab (patch)
tree0ec9b669281f29c9a83d62139dd445bbbc9388b5 /www-servers
parentwww-servers/nginx: drop versions (diff)
downloadgentoo-bf02dbae72b37faec40e8c42f62f952cd47133ab.tar.gz
gentoo-bf02dbae72b37faec40e8c42f62f952cd47133ab.tar.bz2
gentoo-bf02dbae72b37faec40e8c42f62f952cd47133ab.zip
www-servers/nginx: migrate to GLEP-81
Closes: https://bugs.gentoo.org/701254 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/nginx-1.21.6-r2.ebuild (renamed from www-servers/nginx/nginx-1.21.6-r1.ebuild)9
1 files changed, 3 insertions, 6 deletions
diff --git a/www-servers/nginx/nginx-1.21.6-r1.ebuild b/www-servers/nginx/nginx-1.21.6-r2.ebuild
index cbd512501efa..d85839846c7f 100644
--- a/www-servers/nginx/nginx-1.21.6-r1.ebuild
+++ b/www-servers/nginx/nginx-1.21.6-r2.ebuild
@@ -166,7 +166,7 @@ NJS_MODULE_WD="${WORKDIR}/njs-${NJS_MODULE_PV}"
SSL_DEPS_SKIP=1
AUTOTOOLS_AUTO_DEPEND="no"
-inherit autotools lua-single ssl-cert toolchain-funcs perl-module flag-o-matic user systemd multilib pax-utils
+inherit autotools lua-single ssl-cert toolchain-funcs perl-module systemd pax-utils
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
HOMEPAGE="https://nginx.org"
@@ -279,6 +279,8 @@ done
IUSE="${IUSE} nginx_modules_http_spdy"
CDEPEND="
+ acct-group/nginx
+ acct-user/nginx
virtual/libcrypt:=
pcre? ( dev-libs/libpcre:= )
pcre-jit? ( dev-libs/libpcre:=[jit] )
@@ -343,11 +345,6 @@ pkg_setup() {
NGINX_HOME="/var/lib/nginx"
NGINX_HOME_TMP="${NGINX_HOME}/tmp"
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 "${NGINX_HOME}" ${PN}
- eend $?
-
if use libatomic; then
ewarn "GCC 4.1+ features built-in atomic operations."
ewarn "Using libatomic_ops is only needed if using"