summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-01 10:59:13 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-01 10:59:45 +0100
commit622d77b81dbc631fc957590965452b0244a60a76 (patch)
tree7319021b1476c6ff20f4fa83bd4624224e20e2e5 /www-servers
parentapp-text/ronn-ng: drop 0.9.1-r3 (diff)
downloadgentoo-622d77b81dbc631fc957590965452b0244a60a76.tar.gz
gentoo-622d77b81dbc631fc957590965452b0244a60a76.tar.bz2
gentoo-622d77b81dbc631fc957590965452b0244a60a76.zip
www-servers/puma: drop 6.3.1, 6.4.2
Bug: https://bugs.gentoo.org/939950 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest2
-rw-r--r--www-servers/puma/puma-6.3.1.ebuild67
-rw-r--r--www-servers/puma/puma-6.4.2.ebuild68
3 files changed, 0 insertions, 137 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 5393600d395b..b6bce10e715f 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,3 +1 @@
-DIST puma-6.3.1.tar.gz 365566 BLAKE2B 4112406abb05569d8dcaf60826e66ef96ea3cae0639f00b750080fecab6bb86d9fcd1533f15aeae4ffe69a15a103c875e5c73b987cc638e895ff719c6699f310 SHA512 9b7521fa85e50503dcb5b425c7f73909162c6634ae0ada963f93eb82804300637125f159a94166b2446283d092c9dcfa10ccf79a0deabca16a1b27c0d3a37a2f
-DIST puma-6.4.2.tar.gz 387259 BLAKE2B 5d5ee194c2247eb5cf49b81bc2d32c37a52e82eefe94520a952c217663f111ca5dacc54362c522772127882a7c39da8b9ebc6851604cc719db4e170c59559784 SHA512 95f1aa43b019f14160c638ac04bc7648a9f49b5ad418319bcbab90fae7da0e94f122701ce71da864d27c7cc3fe5a2ff5a2ac6b88b8582ea5ce2201d54784af67
DIST puma-6.4.3.tar.gz 388095 BLAKE2B 010009c5c87f4e5f28b6f2b12c65ba447e3d2e1444718df7631a191546096167676b1dab2611fc3aacd4b89a2ec873c0da6a58681b4884acc2dca0e3ec825268 SHA512 20e5800dd978dd681ed4e8dd10c2558d7d4c0cadf79ad25b7974997884cbc8797211761fb5db5303bf7a8e04907634ce9e82ad3e362ae1fff24cc7d770eb5e44
diff --git a/www-servers/puma/puma-6.3.1.ebuild b/www-servers/puma/puma-6.3.1.ebuild
deleted file mode 100644
index d90d242152c6..000000000000
--- a/www-servers/puma/puma-6.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
-
-inherit ruby-fakegem
-
-DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
-HOMEPAGE="https://puma.io/"
-SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE=""
-
-DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
-RDEPEND+=" dev-libs/openssl:0="
-
-ruby_add_bdepend "virtual/ruby-ssl
- test? ( dev-ruby/localhost dev-ruby/rack:2.2 >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
-
-ruby_add_rdepend "dev-ruby/nio4r:2"
-
-all_ruby_prepare() {
- sed -e '/bundler/ s:^:#:' \
- -e '/prove/ s:^:#:' \
- -e '/stub_const/ s:^:#:' \
- -i test/helper.rb || die
-
- # Avoid tests failing inconsistently
- sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
-
- # Avoid tests depending on specific encoding
- sed -i -e '/test_lowlevel_error_handler_response/askip "specific encoding required"' test/test_puma_server.rb || die
-
- # Avoid launcher tests since they make assumptions about bundler use
- rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
-
- # Skip integration tests since they make a lot of assumptions about
- # the environment
- rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
-
- # Avoid test that uses unpackaged stub_const
- sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
-
- # Tries to call 'rackup' directly
- sed -i -e '/def test_bin/,/^ end/ s:^:#:' test/test_rack_handler.rb || die
-
- sed -e 's/git ls-files --/find/' \
- -e 's:_relative ": "./:' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- einfo "Running test suite"
- PUMA_CI_RACK_2=true \
- ${RUBY} -Ilib:.:test \
- -e "gem 'rack', '<3'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{require _1}" || die
-}
diff --git a/www-servers/puma/puma-6.4.2.ebuild b/www-servers/puma/puma-6.4.2.ebuild
deleted file mode 100644
index 5084cdc3b4ec..000000000000
--- a/www-servers/puma/puma-6.4.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
-
-inherit ruby-fakegem
-
-DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
-HOMEPAGE="https://puma.io/"
-SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-
-DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
-RDEPEND+=" dev-libs/openssl:0="
-
-ruby_add_bdepend "virtual/ruby-ssl
- test? ( dev-ruby/localhost dev-ruby/rack:3.0 dev-ruby/rackup >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
-
-ruby_add_rdepend "dev-ruby/nio4r:2"
-
-all_ruby_prepare() {
- sed -e '/\(pride\|prove\|stub_const\)/ s:^:#:' \
- -e '/require_relative.*verbose/ s:^:#:' \
- -e '/securerandom/arequire "rack/handler"' \
- -i test/helper.rb || die
-
- # Avoid tests failing inconsistently
- sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
-
- # Avoid tests depending on specific encoding
- sed -i -e '/test_lowlevel_error_handler_response/askip "specific encoding required"' test/test_puma_server.rb || die
-
- # Avoid launcher tests since they make assumptions about bundler use
- rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
-
- # Skip integration tests since they make a lot of assumptions about
- # the environment
- rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
-
- # Avoid test that uses unpackaged stub_const
- sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
-
- # Avoid test that fails, most likely due to how we run the test suite
- rm -f test/test_url_map.rb || die
-
- # Tries to call 'rackup' directly
- sed -i -e '/def test_bin/,/^ end/ s:^:#:' test/test_rack_handler.rb || die
-
- sed -e 's/git ls-files --/find/' \
- -e 's:_relative ": "./:' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- einfo "Running test suite"
- MT_NO_PLUGINS=true ${RUBY} -Ilib:.:test \
- -e "require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{require _1}" || die
-}