summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-18 07:23:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-18 08:02:57 +0200
commit0650949a523dcec5eaa58efd51f30a77a7c39942 (patch)
tree6d864b9f912dcbd2a2d00a7317babb8904fea8d8 /www-servers
parentdev-python/pyyaml: Bump to 6.0.1 (diff)
downloadgentoo-0650949a523dcec5eaa58efd51f30a77a7c39942.tar.gz
gentoo-0650949a523dcec5eaa58efd51f30a77a7c39942.tar.bz2
gentoo-0650949a523dcec5eaa58efd51f30a77a7c39942.zip
www-servers/gunicorn: Bump to 21.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-21.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 9451c52761a1..38fd0f0ca1e2 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1 +1,2 @@
DIST gunicorn-20.1.0.gh.tar.gz 354960 BLAKE2B bae414a8da7a4dbdf79e0b46f517138534521a1a8544f4ea2e1e27e6778d2f6ad8d6a8af02590fedad47d305acdea53f1cdbc4deeda3619fc4a5ffef0932bea1 SHA512 4fd905f62adc30e044cf2a56a1a77e14bc633258267d6bfbd4f6a68494f93f377e9fb9ed94fab7f11f9d7813857a680974a88c4b6bf97d4f1b74792a81810111
+DIST gunicorn-21.0.1.gh.tar.gz 361025 BLAKE2B bf6b5dafa5b19f9cafe7556339a2ad264f8abbcaf9c8ccdc958f5019a3935b2a1bc3d56411387c578731f0b517d8f31eeb94087abf9fbf99477727b948bb84a3 SHA512 81081192ad5400f65898a37524ef097a3793aa242028ea30de7b478b605fb14dccdd0eb18d9e8102d8218c33a228143637fec7e02902ceaaa8ce95ea8a2f8be4
diff --git a/www-servers/gunicorn/gunicorn-21.0.1.ebuild b/www-servers/gunicorn/gunicorn-21.0.1.ebuild
new file mode 100644
index 000000000000..e08fbcb4748f
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-21.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="
+ https://gunicorn.org/
+ https://github.com/benoitc/gunicorn/
+ https://pypi.org/project/gunicorn/
+"
+SRC_URI="
+ https://github.com/benoitc/gunicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # removed deps
+ tests/workers/test_geventlet.py
+ tests/workers/test_ggevent.py
+)
+
+src_prepare() {
+ sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}