summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-17 08:25:20 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-17 08:26:25 -0800
commit76dfce4ab8c325420e7f5eb092e73f8a2c734694 (patch)
tree4e3e53894bbc2a4433b39d35f48c574e89d3e4cb /www-servers/tornado/files
parentmedia-libs/libpng: Security cleanup (bug #604082). (diff)
downloadgentoo-76dfce4ab8c325420e7f5eb092e73f8a2c734694.tar.gz
gentoo-76dfce4ab8c325420e7f5eb092e73f8a2c734694.tar.bz2
gentoo-76dfce4ab8c325420e7f5eb092e73f8a2c734694.zip
www-servers/tornado: Cleanup vulnerable versions
X-Gentoo-bug: 597740 X-Gentoo-bug-url: https://bugs.gentoo.org/show_bug.cgi?id=597740 Package-Manager: Portage-2.3.3_p23, Repoman-2.3.1_p16
Diffstat (limited to 'www-servers/tornado/files')
-rw-r--r--www-servers/tornado/files/drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch63
2 files changed, 0 insertions, 99 deletions
diff --git a/www-servers/tornado/files/drop-intersphinx.patch b/www-servers/tornado/files/drop-intersphinx.patch
deleted file mode 100644
index 7502dc53b820..000000000000
--- a/www-servers/tornado/files/drop-intersphinx.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/docs/Makefile b/docs/Makefile
-index 7001b80..ab2ffdd 100644
---- a/docs/Makefile
-+++ b/docs/Makefile
-@@ -3,7 +3,7 @@ all: sphinx
-
- # No -W for doctests because that disallows tests with empty output.
- SPHINX_DOCTEST_OPTS=-n -d build/doctress .
--SPHINXOPTS=-n -W -d build/doctrees .
-+SPHINXOPTS=-n -d build/doctrees .
-
- .PHONY: sphinx
- sphinx:
-diff --git a/docs/conf.py b/docs/conf.py
-index 368e4e8..85a276d 100644
---- a/docs/conf.py
-+++ b/docs/conf.py
-@@ -16,7 +16,6 @@ extensions = [
- "sphinx.ext.coverage",
- "sphinx.ext.doctest",
- "sphinx.ext.extlinks",
-- "sphinx.ext.intersphinx",
- "sphinx.ext.viewcode",
- ]
-
-@@ -91,10 +90,6 @@ extlinks = {
- 'tornado-%s.tar.g' % version),
- }
-
--intersphinx_mapping = {
-- 'python': ('https://docs.python.org/3.4/', None),
-- }
--
- on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
-
- # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch b/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch
deleted file mode 100644
index e649935d7048..000000000000
--- a/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 2971e857104f8d02fa9107a0e13f50170eb4f30d Mon Sep 17 00:00:00 2001
-From: Ben Darnell <ben@bendarnell.com>
-Date: Sat, 6 Jun 2015 15:40:21 -0400
-Subject: [PATCH] Get the tests passing under Python 3.5b2
-
----
- tornado/test/web_test.py | 7 +++++--
- tornado/util.py | 10 ++++++++--
- 2 files changed, 13 insertions(+), 4 deletions(-)
-
-diff --git a/tornado/test/web_test.py b/tornado/test/web_test.py
-index 96edd6c..a93369c 100644
---- a/tornado/test/web_test.py
-+++ b/tornado/test/web_test.py
-@@ -1538,8 +1538,11 @@ def get(self):
- def test_clear_all_cookies(self):
- response = self.fetch('/', headers={'Cookie': 'foo=bar; baz=xyzzy'})
- set_cookies = sorted(response.headers.get_list('Set-Cookie'))
-- self.assertTrue(set_cookies[0].startswith('baz=;'))
-- self.assertTrue(set_cookies[1].startswith('foo=;'))
-+ # Python 3.5 sends 'baz="";'; older versions use 'baz=;'
-+ self.assertTrue(set_cookies[0].startswith('baz=;') or
-+ set_cookies[0].startswith('baz="";'))
-+ self.assertTrue(set_cookies[1].startswith('foo=;') or
-+ set_cookies[1].startswith('foo="";'))
-
-
- class PermissionError(Exception):
-diff --git a/tornado/util.py b/tornado/util.py
-index 606ced1..ea4da87 100644
---- a/tornado/util.py
-+++ b/tornado/util.py
-@@ -13,7 +13,6 @@
- from __future__ import absolute_import, division, print_function, with_statement
-
- import array
--import inspect
- import os
- import sys
- import zlib
-@@ -24,6 +23,13 @@
- except NameError:
- xrange = range # py3
-
-+# inspect.getargspec() raises DeprecationWarnings in Python 3.5.
-+# The two functions have compatible interfaces for the parts we need.
-+try:
-+ from inspect import getfullargspec as getargspec # py3
-+except ImportError:
-+ from inspect import getargspec # py2
-+
-
- class ObjectDict(dict):
- """Makes a dictionary behave like an object, with attribute-style access.
-@@ -284,7 +290,7 @@ class ArgReplacer(object):
- def __init__(self, func, name):
- self.name = name
- try:
-- self.arg_pos = inspect.getargspec(func).args.index(self.name)
-+ self.arg_pos = getargspec(func).args.index(self.name)
- except ValueError:
- # Not a positional parameter
- self.arg_pos = None