summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-11 22:49:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-12 15:05:51 +0100
commit274d6506e47717e007c93157cbe9720feb627a40 (patch)
tree28980597516dd8c52722fe0702656f85ed600353 /www-misc
parentdev-python/pushbullet-py: new package, v. 0.10.0, optional dep of urlwatch. (diff)
downloadgentoo-274d6506e47717e007c93157cbe9720feb627a40.tar.gz
gentoo-274d6506e47717e007c93157cbe9720feb627a40.tar.bz2
gentoo-274d6506e47717e007c93157cbe9720feb627a40.zip
www-misc/urlwatch: version bump to 2.6.
This version adds support for Pushbullet notifications thanks to the new package 'dev-python/pushbullet-py'. Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3437
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 4b2b452d8fa5..8e0176c3c547 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1 +1,2 @@
DIST urlwatch-2.5.tar.gz 25322 SHA256 6010a45dbc20d5449f214655c94977a65e1e2b8ba32f58e9045ddfdaaabf3962 SHA512 993d2596288d014a3b84ae22c29ce89282c4320dd95b339c9892db07997059fc80a96198cb89ba04d935f68d2d051da96dc981f8e8b3657492443b060d2126a1 WHIRLPOOL d8be345d19027e475825d708f9ce2c55fe4abb23e903d629aec872104a0e890f225dfe3f1c8de87541e9cbed7c62592d362e464f3014f0a7ce27000fd9a5f880
+DIST urlwatch-2.6.tar.gz 30412 SHA256 57a90a0a7a3f056bbf77c917621a124338de20e15ce356873b9abba72f57d6f4 SHA512 52d71984972c6888ade01fcc635d33a60c024424b82ac9319554f548438f8a4e2f32a8b7d3047ed86654c8ef67e3b6eac99728f9409b60cdffe7e842fd8fe16c WHIRLPOOL 29ffa3606e5ba00006b3f3767beef2804c2952453fd11db9aa3cb99515dc347f215c127df5bef38ee185e0c89ab8edd377bb4066d1b8a65b6085ec251dc436b6
diff --git a/www-misc/urlwatch/urlwatch-2.6.ebuild b/www-misc/urlwatch/urlwatch-2.6.ebuild
new file mode 100644
index 000000000000..43074696abd7
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
+SRC_URI="https://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || ( www-client/lynx app-text/html2text )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ fi
+}