summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-11-08 20:04:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-08 20:07:24 +0200
commitf6db890f35f8d70b829a6a2e5d2a98b87da0ca70 (patch)
treebad1573b04c18d06e7af2c09df09c40b0b287117 /www-client
parentdev-util/gitlab-runner: stabilize 15.4.1 for amd64 (diff)
downloadgentoo-f6db890f35f8d70b829a6a2e5d2a98b87da0ca70.tar.gz
gentoo-f6db890f35f8d70b829a6a2e5d2a98b87da0ca70.tar.bz2
gentoo-f6db890f35f8d70b829a6a2e5d2a98b87da0ca70.zip
www-client/firefox: switch from llvm-as to "clang -c"
Closes: https://bugs.gentoo.org/879177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-102.4.0.ebuild4
-rw-r--r--www-client/firefox/firefox-106.0.5.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-102.4.0.ebuild b/www-client/firefox/firefox-102.4.0.ebuild
index 0d52f3b9361f..49346cd4dda6 100644
--- a/www-client/firefox/firefox-102.4.0.ebuild
+++ b/www-client/firefox/firefox-102.4.0.ebuild
@@ -625,7 +625,7 @@ src_configure() {
have_switched_compiler=yes
fi
AR=llvm-ar
- AS=llvm-as
+ AS="clang -c"
CC=${CHOST}-clang
CXX=${CHOST}-clang++
NM=llvm-nm
@@ -650,7 +650,7 @@ src_configure() {
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
+ tc-export CC CXX LD AR AS NM OBJDUMP RANLIB PKG_CONFIG
# Pass the correct toolchain paths through cbindgen
if tc-is-cross-compiler ; then
diff --git a/www-client/firefox/firefox-106.0.5.ebuild b/www-client/firefox/firefox-106.0.5.ebuild
index e718211685a9..84b885c8cd46 100644
--- a/www-client/firefox/firefox-106.0.5.ebuild
+++ b/www-client/firefox/firefox-106.0.5.ebuild
@@ -670,7 +670,7 @@ src_configure() {
have_switched_compiler=yes
fi
AR=llvm-ar
- AS=llvm-as
+ AS="clang -c"
CC=${CHOST}-clang
CXX=${CHOST}-clang++
NM=llvm-nm
@@ -695,7 +695,7 @@ src_configure() {
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
+ tc-export CC CXX LD AR AS NM OBJDUMP RANLIB PKG_CONFIG
# Pass the correct toolchain paths through cbindgen
if tc-is-cross-compiler ; then