summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-04-15 22:48:52 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-04-15 22:50:59 +0200
commitd3a8859fe132fe40267048ba654e117838f1c912 (patch)
tree85792a96b504fe45a2d04243bf07c47f86d48a23 /www-client
parentnet-misc/ytfzf: add 2.3 (diff)
downloadgentoo-d3a8859fe132fe40267048ba654e117838f1c912.tar.gz
gentoo-d3a8859fe132fe40267048ba654e117838f1c912.tar.bz2
gentoo-d3a8859fe132fe40267048ba654e117838f1c912.zip
www-client/microsoft-edge: automated bump (100.0.1185.44)
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-100.0.1185.44.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 0993cd95b667..637470fb120e 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_100.0.1185.39-1_amd64.deb 119213224 BLAKE2B 1dd6a953a6d4ac081e6542c2d8c320ab87dcb1d104a459ccc258c901991601ea71f33887c322a8692e98d8e7a8aa01b0bbf41db760bad4f173d221bb6720c56a SHA512 1c96fa51c8674e77af2d2ddc8eb6ccd3034418c22afd432c4744d7fbb5f21e8dd7b1a0cc5c0d02b7c10e802a2b519c0d9291610a8643457192acd2b3ee24091d
+DIST microsoft-edge-stable_100.0.1185.44-1_amd64.deb 119252344 BLAKE2B a106e5cece8f03be7442d39d6d66ae050e3905a66cb7bb193352d70da894314a820cf11d81011bdae8836215ecbae4d3a4edc892fbf81d11b2b4bed60f979e06 SHA512 3e558e6fd38eaa8cd4f40a10a1c04955cefc751b74e4c6b429aad8df2ae257102903a1a1429f24d58a1bcded3e72e752dc4f741ea69da51faba62954989815fc
diff --git a/www-client/microsoft-edge/microsoft-edge-100.0.1185.44.ebuild b/www-client/microsoft-edge/microsoft-edge-100.0.1185.44.ebuild
new file mode 100644
index 000000000000..a8cc7e730ebf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-100.0.1185.44.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}