summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-03 13:51:23 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-03 14:08:47 -0600
commit8127c76258dcf546f077b3527f4e3a9a9d88c3ea (patch)
treef5a2f3fcf04c9938af4c5c6e6c9482abc4bd40de /www-client
parentdev-libs/crypto++: fix amd64 asm (diff)
downloadgentoo-8127c76258dcf546f077b3527f4e3a9a9d88c3ea.tar.gz
gentoo-8127c76258dcf546f077b3527f4e3a9a9d88c3ea.tar.bz2
gentoo-8127c76258dcf546f077b3527f4e3a9a9d88c3ea.zip
www-client/lynx: version bump to 2.9.0_pre1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/Manifest1
-rw-r--r--www-client/lynx/lynx-2.9.0_pre1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/www-client/lynx/Manifest b/www-client/lynx/Manifest
index 4d4a15e592b5..1146a51cb277 100644
--- a/www-client/lynx/Manifest
+++ b/www-client/lynx/Manifest
@@ -1,2 +1,3 @@
DIST lynx2.8.9dev.16.tar.bz2 2674662 BLAKE2B 3771199e4d74dcc38c15b8b75207810d3a4f3afabb76d5d8dc7dcd33c5dd0119f0f28a1a719f54df7ed0ecdfb972942c6439536486f99a685febbc252127cc3f SHA512 6aa5e869924c6e42aa68113985aecfb75dc6eb68d5d7db8cedb9843621d29c36c17078e7a692f472e3e7f1edf7ca666e3614bc3bdb092a3631877733d5e3d518
DIST lynx2.8.9rel.1.tar.bz2 2689171 BLAKE2B 7cff536660e8fe77d40a56262c2f12e2093ffbb3e22a5ac8e7eab4410f0255e98df19e51f0c98d53aeb3ba63d0d1c2fcabe145242811bebcafb6e548a162a9fb SHA512 61edbe082684fcbd91bdbf4f4d27c3baf92358811aaffc2f8af46adf23ca7b48aede1520fc5f2a8fc974a2f4bbf4e57e7e6027a187bfc6101e56878c98178e6d
+DIST lynx2.9.0dev.1.tar.bz2 2689103 BLAKE2B c82b208e8628efc0f01f35be554fa9c7de0f942cbd76307f7c8aa0d04638a9b89e206e84603c750096036e3469a310d274079caf6a535f15041e119046014845 SHA512 b17361de68fccb8f446210f806fb325468110354858353bc8aaf9b9ae38f9c9f33f592b9fc5ffd31738fe632032cc952347391cd77c5a7b5e5b85be579203e19
diff --git a/www-client/lynx/lynx-2.9.0_pre1.ebuild b/www-client/lynx/lynx-2.9.0_pre1.ebuild
new file mode 100644
index 000000000000..c5180789737d
--- /dev/null
+++ b/www-client/lynx/lynx-2.9.0_pre1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# VERSIONING SCHEME TRANSLATION
+# Upstream : Gentoo
+# rel. : _p
+# pre. : _rc
+# dev. : _pre
+
+case ${PV} in
+ *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
+ *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
+ *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
+esac
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.invisible-island.net/"
+SRC_URI="http://invisible-mirror.net/archives/lynx/tarballs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode libressl"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ ssl? (
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ gnutls? (
+ dev-libs/libgcrypt:0=
+ >=net-libs/gnutls-2.6.4:=
+ )
+ )
+ bzip2? ( app-arch/bzip2 )
+ idn? ( net-dns/libidn:0= )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.8.6-mint.patch
+ "${FILESDIR}"/${PN}-2.8.9_p1-parallel.patch
+)
+
+pkg_setup() {
+ ! use ssl && elog "SSL support disabled; you will not be able to access secure websites."
+}
+
+src_configure() {
+ local myconf=(
+ --enable-nested-tables
+ --enable-cgi-links
+ --enable-persistent-cookies
+ --enable-prettysrc
+ --enable-nsl-fork
+ --enable-file-upload
+ --enable-read-eta
+ --enable-color-style
+ --enable-scrollbar
+ --enable-included-msgs
+ --enable-externs
+ --with-zlib
+ $(use_enable nls)
+ $(use_enable idn idna)
+ $(use_enable ipv6)
+ $(use_enable cjk)
+ $(use_enable unicode japanese-utf8)
+ $(use_with bzip2 bzlib)
+ $(usex ssl "--with-$(usex gnutls gnutls ssl)=${EPREFIX}/usr" "")
+ --with-screen=$(usex unicode "ncursesw" "ncurses")
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # generating translation files in parallel is currently broken
+ use nls && emake -C po -j1
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ sed -i "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
+ if use unicode ; then
+ sed -i '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
+ "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
+ fi
+
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ dodoc -r docs lynx_help
+}