summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-02-04 09:24:39 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-02-04 09:25:54 +0100
commit32cbcd88b3907b5b82ddebea11a9130c4a1fb0d1 (patch)
tree1f0eae69a0b7de47c08a1b6f926d2cfe439d1b6d /www-client
parentdev-java/jackson-annotations: Drop 2.9.10 (diff)
downloadgentoo-32cbcd88b3907b5b82ddebea11a9130c4a1fb0d1.tar.gz
gentoo-32cbcd88b3907b5b82ddebea11a9130c4a1fb0d1.tar.bz2
gentoo-32cbcd88b3907b5b82ddebea11a9130c4a1fb0d1.zip
www-client/microsoft-edge: automated bump (98.0.1108.43)
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/metadata.xml3
-rw-r--r--www-client/microsoft-edge/microsoft-edge-98.0.1108.43.ebuild115
3 files changed, 119 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 9b002ef13fa8..b4d857d2d77a 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_97.0.1072.76-1_amd64.deb 119913002 BLAKE2B 9157d9dd89479adaf3680c7227058af2804a85066e8820abc40c9be35e193bd42f15278d2f2d5bfbd4238183d72e5ccba45e21eac1362ebe6a57faebd5f18c0d SHA512 cfaedd5222b0de808eea4e8eab829466368575ac95e80cb66e1a125dfbccf6c0dd2742140fac1384ebb7574548b8f6b189a31b016eb7fd2578b79d023e484f14
+DIST microsoft-edge-stable_98.0.1108.43-1_amd64.deb 124175258 BLAKE2B 34fdd3d3aed914d00909864cbdb49107f93a7e0e9b25f5d061d07b25895a2c6ae8f885bf084b9927d89b898aec67f94f6ecc402df50d4e5616eb89a37d11761f SHA512 7b4ea49f9526ad5053c3e235819d26dc4b04f63787bf90b230b125f6f6a19a19c0e954e15ed372d68e3b29015fe3d8cf25861e8b1935540506b24a6b87dd325f
diff --git a/www-client/microsoft-edge/metadata.xml b/www-client/microsoft-edge/metadata.xml
index c4f491930d33..a7689ec3a837 100644
--- a/www-client/microsoft-edge/metadata.xml
+++ b/www-client/microsoft-edge/metadata.xml
@@ -9,4 +9,7 @@
Microsoft Edge is a browser that combines a minimal design with
sophisticated technology to make the web faster, safer, and easier.
</longdescription>
+ <use>
+ <flag name="mip">Install Microsoft Information Protection plugin.</flag>
+ </use>
</pkgmetadata>
diff --git a/www-client/microsoft-edge/microsoft-edge-98.0.1108.43.ebuild b/www-client/microsoft-edge/microsoft-edge-98.0.1108.43.ebuild
new file mode 100644
index 000000000000..3e1b323cccbf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-98.0.1108.43.ebuild
@@ -0,0 +1,115 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}