summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-27 17:55:48 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-27 17:56:20 -0500
commit141059e3d9e1295de9e428f08a31d83aae3d18e0 (patch)
tree5577be4093aa06e9d6e4330abccee8c1196b57a4 /www-client
parentprofiles: Mask app-text/searchmonkey for removal (diff)
downloadgentoo-141059e3d9e1295de9e428f08a31d83aae3d18e0.tar.gz
gentoo-141059e3d9e1295de9e428f08a31d83aae3d18e0.tar.bz2
gentoo-141059e3d9e1295de9e428f08a31d83aae3d18e0.zip
www-client/chromium: beta channel bump (65.0.3325.88)
Package-Manager: Portage-2.3.24_p18, Repoman-2.3.6_p99
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/Manifest2
-rw-r--r--www-client/chromium/chromium-65.0.3325.88.ebuild (renamed from www-client/chromium/chromium-65.0.3315.3.ebuild)87
2 files changed, 50 insertions, 39 deletions
diff --git a/www-client/chromium/Manifest b/www-client/chromium/Manifest
index 30ed7155bf8c..49fb9e58e9cc 100644
--- a/www-client/chromium/Manifest
+++ b/www-client/chromium/Manifest
@@ -1,4 +1,4 @@
DIST chromium-64.0.3282.167.tar.xz 482246360 BLAKE2B b4785c20f33081015ac31fed9dbd108dc78160d95c4ea7055b8fffdb714fe9ef120727cd6b88d4e4a15b0c429f04c7c512cca90c5313128e0001a4ae5b908b6f SHA512 1bee80d2e8d4332cfc307efdac8eb11a48e42f3927e63e7a9d5ff2bbad6c4534926669f21defbf0553160f5bb28596723be8bd0e3dfa19ca9a1e854bcf42fd77
DIST chromium-64.0.3282.186.tar.xz 482247144 BLAKE2B b59c5afeeed33fe081f35d0ee228a0d67a97fc1370c7d3ab90304ea6e236ee0f7fecd2c36df0acbdf384f42e2f90926cbdd56e683afc95e78d4bdc64b6d24453 SHA512 a8a435ee8506cfefaaf2df7447010df5db69fa6907844872d00643f55723a9bd7771649658f5151c857ac037adcbc8bdf2a5375dd105f78d068277ef021af7d8
-DIST chromium-65.0.3315.3.tar.xz 532475512 BLAKE2B 1a118ddd05f2b939ff0fd84f85e1c22789713351776d889bafb55ddb2b897b2921050a3df3b7d5e3224be84539d95dddce1a27a948c61b29c788ed9f8e194e02 SHA512 c7f0feda90c0df15058473d39482e9b9a9b3236dcb90ff8ba7ad53afde2fce4901b2cbd678d8470560cc0cb6e31c8d3caee9f0a9f100d82d95feacabcdb7f8ce
DIST chromium-65.0.3325.73.tar.xz 570268564 BLAKE2B 8d1a9cf38f12ea3566463f42772671268de68d8c49170d60733be8eee7492850be739f19377365366740dcbad3414538eb00765281c966b6cedb85b74709448f SHA512 96ed3862c3fc21afac8d18f4b43f98d29a086e83dfe25af54b6358e139a8b3c9ec761cc463ce287b04a9082c5e62dbc605d4c97f8ec358599a24c7830c890418
+DIST chromium-65.0.3325.88.tar.xz 570275184 BLAKE2B a08ae19acfd7a80ae43c0654432588bfa7ea09a0b0f14583cf8e79b3c5997a348bcba12e52002d79214576030574695d32069cbe7037b53dad120aadf6c2a830 SHA512 5166e64f96e5b2bd30b28ed769a8c93b2c1de3eb52c18776222b16758002b6d87ca241bd95c7b37316e1afc5379ff49b77fbf552ab9c0ea868105d66ce400070
diff --git a/www-client/chromium/chromium-65.0.3315.3.ebuild b/www-client/chromium/chromium-65.0.3325.88.ebuild
index c2d2f2fcaf78..ede298f25fde 100644
--- a/www-client/chromium/chromium-65.0.3315.3.ebuild
+++ b/www-client/chromium/chromium-65.0.3325.88.ebuild
@@ -101,6 +101,7 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
+ >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
$(python_gen_any_dep '
@@ -150,23 +151,23 @@ PATCHES=(
"${FILESDIR}/chromium-memcpy-r0.patch"
"${FILESDIR}/chromium-clang-r2.patch"
"${FILESDIR}/chromium-gn-r0.patch"
- "${FILESDIR}/chromium-vulkan-r0.patch"
- "${FILESDIR}/chromium-gcc-r0.patch"
- "${FILESDIR}/chromium-ffmpeg-r0.patch"
+ "${FILESDIR}/chromium-math.h-r0.patch"
+ "${FILESDIR}/chromium-clang-r3.patch"
+ "${FILESDIR}/chromium-stdint.patch"
)
pre_build_checks() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- local -x CPP="$(tc-getCXX) -E"
- if tc-is-clang && ! version_is_at_least "3.9.1" "$(clang-fullversion)"; then
- # bugs: #601654
- die "At least clang 3.9.1 is required"
- fi
- if tc-is-gcc && ! version_is_at_least 5.0 "$(gcc-version)"; then
- # bugs: #535730, #525374, #518668, #600288, #627356
- die "At least gcc 5.0 is required"
- fi
- fi
+ #if [[ ${MERGE_TYPE} != binary ]]; then
+ # local -x CPP="$(tc-getCXX) -E"
+ # if tc-is-clang && ! version_is_at_least "3.9.1" "$(clang-fullversion)"; then
+ # # bugs: #601654
+ # die "At least clang 3.9.1 is required"
+ # fi
+ # if tc-is-gcc && ! version_is_at_least 5.0 "$(gcc-version)"; then
+ # # bugs: #535730, #525374, #518668, #600288, #627356
+ # die "At least gcc 5.0 is required"
+ # fi
+ #fi
# Check build requirements, bug #541816 and bug #471810 .
CHECKREQS_MEMORY="3G"
@@ -265,7 +266,6 @@ src_prepare() {
third_party/libXNVCtrl
third_party/libaddressinput
third_party/libaom
- third_party/libaom/source/libaom/third_party/x86inc
third_party/libjingle
third_party/libphonenumber
third_party/libsecret
@@ -274,6 +274,7 @@ src_prepare() {
third_party/libwebm
third_party/libxml/chromium
third_party/libyuv
+ third_party/llvm
third_party/lss
third_party/lzma_sdk
third_party/markupsafe
@@ -374,6 +375,32 @@ src_configure() {
local myconf_gn=""
+ # Make sure the build system will use the right tools, bug #340795.
+ tc-export AR CC CXX NM
+
+ if ! tc-is-clang; then
+ # Force clang since gcc is pretty broken at the moment.
+ CC=clang
+ CXX=clang++
+ fi
+
+ if tc-is-clang; then
+ myconf_gn+=" is_clang=true clang_use_chrome_plugins=false"
+ else
+ myconf_gn+=" is_clang=false"
+ fi
+
+ # Define a custom toolchain for GN
+ myconf_gn+=" custom_toolchain=\"//build/toolchain/linux/unbundle:default\""
+
+ if tc-is-cross-compiler; then
+ tc-export BUILD_{AR,CC,CXX,NM}
+ myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:host\""
+ myconf_gn+=" v8_snapshot_toolchain=\"//build/toolchain/linux/unbundle:host\""
+ else
+ myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:default\""
+ fi
+
# GN needs explicit config for Debug/Release as opposed to inferring it from build directory.
myconf_gn+=" is_debug=false"
@@ -442,12 +469,6 @@ src_configure() {
myconf_gn+=" fieldtrial_testing_like_official_build=true"
- if tc-is-clang; then
- myconf_gn+=" is_clang=true clang_use_chrome_plugins=false"
- else
- myconf_gn+=" is_clang=false"
- fi
-
# Never use bundled gold binary. Disable gold linker flags for now.
# Do not use bundled clang.
# Trying to use gold results in linker crash.
@@ -512,22 +533,8 @@ src_configure() {
fi
fi
- # Make sure the build system will use the right tools, bug #340795.
- tc-export AR CC CXX NM
-
- # Define a custom toolchain for GN
- myconf_gn+=" custom_toolchain=\"//build/toolchain/linux/unbundle:default\""
-
- if tc-is-cross-compiler; then
- tc-export BUILD_{AR,CC,CXX,NM}
- myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:host\""
- myconf_gn+=" v8_snapshot_toolchain=\"//build/toolchain/linux/unbundle:host\""
- else
- myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:default\""
- fi
-
# https://bugs.gentoo.org/588596
- append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+ #append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
# Bug 491582.
export TMPDIR="${WORKDIR}/temp"
@@ -561,6 +568,8 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+
# Build mksnapshot and pax-mark it.
local x
for x in mksnapshot v8_context_snapshot_generator; do
@@ -634,8 +643,10 @@ src_install() {
doins -r out/Release/locales
doins -r out/Release/resources
- insinto "${CHROMIUM_HOME}/swiftshader"
- doins out/Release/swiftshader/*.so
+ if [[ -d out/Release/swiftshader ]]; then
+ insinto "${CHROMIUM_HOME}/swiftshader"
+ doins out/Release/swiftshader/*.so
+ fi
# Install icons and desktop entry.
local branding size