summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-24 16:36:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-24 20:01:11 -0400
commit1c5557f964a70a4cb1ef70420586035df288ac6f (patch)
tree902df0f3b306c213fe8f80efbb9f405ae0c39a39 /www-client/qutebrowser
parentdev-python/cheroot: enable py3.12 (diff)
downloadgentoo-1c5557f964a70a4cb1ef70420586035df288ac6f.tar.gz
gentoo-1c5557f964a70a4cb1ef70420586035df288ac6f.tar.bz2
gentoo-1c5557f964a70a4cb1ef70420586035df288ac6f.zip
www-client/qutebrowser: add note wrt py3.12 in live
Last blocker is pyside2+6 to enable py3.12 on QtPy which is needed by pytest-qt, but tests on pyside are restricted and I do not use/follow either of these to be able to know if it works. If ignore the pyside deps and force enable 3.12 just to be able to run qutebrowser's tests, it passes fine. Leaving this on hold for now so don't need to restrict tests. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 56936f3f91bd..5df6b9fbacf4 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -5,7 +5,10 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+# py3.12 should work (no tests regressions), but waiting on the last dep
+# (pytest-qt) to properly have py3.12 which gets more complicated with
+# QtPy + pyside* that we don't actually use here
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 xdg
if [[ ${PV} == 9999 ]]; then