summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-31 01:47:10 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-31 01:47:25 +0100
commit5eaa2e2b3465597a97aee855fbf5c97e3209d0f8 (patch)
treeb9e07c1687ca1d769ba6184b5c92a806340ca6fe /www-client/netsurf/files
parentwww-plugins/chrome-binary-plugins: automated update (57.0.2987.13) (diff)
downloadgentoo-5eaa2e2b3465597a97aee855fbf5c97e3209d0f8.tar.gz
gentoo-5eaa2e2b3465597a97aee855fbf5c97e3209d0f8.tar.bz2
gentoo-5eaa2e2b3465597a97aee855fbf5c97e3209d0f8.zip
www-client/netsurf: Fix USE=gstreamer (bug 607650, thanks ernsteiswuerfel), limit NETSURF_USE_VIDEO to gtk/gtk3 versions.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'www-client/netsurf/files')
-rw-r--r--www-client/netsurf/files/netsurf-3.6-gstreamer.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-client/netsurf/files/netsurf-3.6-gstreamer.patch b/www-client/netsurf/files/netsurf-3.6-gstreamer.patch
new file mode 100644
index 000000000000..6aca4f6abdf9
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.6-gstreamer.patch
@@ -0,0 +1,31 @@
+--- netsurf-3.6/frontends/gtk/Makefile
++++ netsurf-3.6/frontends/gtk/Makefile
+@@ -16,7 +16,6 @@
+
+ # GTK and GLIB flags to disable depricated usage
+ GTKDEPFLAGS := -DG_DISABLE_SINGLE_INCLUDES \
+- -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_SINGLE_INCLUDES \
+ -DGTK_MULTIHEAD_SAFE \
+ -DPANGO_DISABLE_DEPRECATED
+--- netsurf-3.6/content/handlers/image/video.c
++++ netsurf-3.6/content/handlers/image/video.c
+@@ -22,6 +22,8 @@
+ #include "content/content_protected.h"
+
+ #include "image/video.h"
++#include "utils/http/parameter.h"
++#include "content/llcache.h"
+
+ typedef struct nsvideo_content {
+ struct content base;
+--- netsurf-3.6/content/content_factory.h
++++ netsurf-3.6/content/content_factory.h
+@@ -25,6 +25,7 @@
+
+ #include "netsurf/content_type.h"
+ #include "utils/errors.h"
++#include "utils/utils.h"
+
+ #define CONTENT_FACTORY_REGISTER_TYPES(HNAME, HTYPELIST, HHANDLER) \
+ \