summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-10-29 09:37:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-10-29 09:37:31 +0200
commite64a17210c65081ee68e1e63031e66e45b6bc09c (patch)
tree1f05bf9082d5dd2e5d3e4e5eecfc5d9387800763 /www-client/firefox-bin
parentdev-python/pythran: fix test linkage with blas (diff)
downloadgentoo-e64a17210c65081ee68e1e63031e66e45b6bc09c.tar.gz
gentoo-e64a17210c65081ee68e1e63031e66e45b6bc09c.tar.bz2
gentoo-e64a17210c65081ee68e1e63031e66e45b6bc09c.zip
www-client/firefox-bin: fix 119.0 when using apulse
Closes: https://bugs.gentoo.org/916230 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/firefox-bin')
-rw-r--r--www-client/firefox-bin/firefox-bin-119.0-r2.ebuild (renamed from www-client/firefox-bin/firefox-bin-119.0-r1.ebuild)28
1 files changed, 8 insertions, 20 deletions
diff --git a/www-client/firefox-bin/firefox-bin-119.0-r1.ebuild b/www-client/firefox-bin/firefox-bin-119.0-r2.ebuild
index c9ed54000aeb..83ea6b313337 100644
--- a/www-client/firefox-bin/firefox-bin-119.0-r1.ebuild
+++ b/www-client/firefox-bin/firefox-bin-119.0-r2.ebuild
@@ -43,19 +43,7 @@ IUSE="+alsa +ffmpeg +gmp-autoupdate +pulseaudio selinux wayland"
RESTRICT="strip"
-BDEPEND="app-arch/unzip
- alsa? (
- !pulseaudio? (
- dev-util/patchelf
- )
- )"
-
-DEPEND="alsa? (
- !pulseaudio? (
- media-sound/apulse
- )
- )"
-
+BDEPEND="app-arch/unzip"
RDEPEND="${DEPEND}
!www-client/firefox-bin:0
!www-client/firefox-bin:esr
@@ -212,13 +200,6 @@ src_install() {
"${ED}${MOZILLA_FIVE_HOME}"/${MOZ_PN}-bin \
"${ED}${MOZILLA_FIVE_HOME}"/plugin-container
- # Patch alsa support
- local apulselib=
- if use alsa && ! use pulseaudio ; then
- apulselib="${EPREFIX}/usr/$(get_libdir)/apulse"
- patchelf --set-rpath "${apulselib}" "${ED}${MOZILLA_FIVE_HOME}/libxul.so" || die
- fi
-
# Install policy (currently only used to disable application updates)
insinto "${MOZILLA_FIVE_HOME}/distribution"
newins "${FILESDIR}"/disable-auto-update.policy.json policies.json
@@ -279,6 +260,13 @@ src_install() {
cp "${desktop_file}" "${WORKDIR}/${PN}.desktop-template" || die
+ # Add apulse support through our wrapper shell launcher, patchelf-method broken since 119.0.
+ # See bgo#916230
+ local apulselib=
+ if use alsa && ! use pulseaudio ; then
+ apulselib="${EPREFIX}/usr/$(get_libdir)/apulse"
+ fi
+
sed -i \
-e "s:@NAME@:${app_name}:" \
-e "s:@EXEC@:${exec_command}:" \