summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-25 19:29:17 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-25 19:29:29 -0700
commitc925fa75011b89157ae8afc9d9791e1fe77be56d (patch)
treea3b60e8f2d5b49a69732500de59e154d8cd1e61a /www-client/epiphany
parentnet-libs/webkit-gtk: Version bump to 2.36.0 (diff)
downloadgentoo-c925fa75011b89157ae8afc9d9791e1fe77be56d.tar.gz
gentoo-c925fa75011b89157ae8afc9d9791e1fe77be56d.tar.bz2
gentoo-c925fa75011b89157ae8afc9d9791e1fe77be56d.zip
www-client/epiphany: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-42.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index e5c08a1b3204..9e83b33f8977 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-41.3.tar.xz 6153540 BLAKE2B bd95f643be4947818ebfafb1316a03c7c6cf118a45583f07e9fde60e32dabd63edf173673b86e454d9af066769950276cf77ea50fac8dd204fcae06c6ad04126 SHA512 1effef22291687c8ff2252eced24274db3b1f4afacfc3053a33cae85112759918f80d824bb02b7e17d95364eec0062cb3459a6079783d9c900874cc150ea98ba
+DIST epiphany-42.0.tar.xz 6101296 BLAKE2B 768c2547d5e3644a43287522c7445fe23fe5a7af4e22dd0ff8959cd6c5e0537e593f1f6b81b10c603d8355bc1af6df36b60bdab70de1b60e7e40df758c956651 SHA512 225243cbae1659367e881991c191a766b47e0710a3e58c0eb56fba67ab8e527922a84e4663207a80d14da9c99102ea16c030f12f7444e6e2678b5c8cf7dc99e0
diff --git a/www-client/epiphany/epiphany-42.0.ebuild b/www-client/epiphany/epiphany-42.0.ebuild
new file mode 100644
index 000000000000..cdecea5a8e9f
--- /dev/null
+++ b/www-client/epiphany/epiphany-42.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.67.4:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.33.2:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.5.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dsoup2=enabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}