summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-06-19 16:00:04 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-19 16:09:35 +1000
commit3f00c5083bfb37f1ed8b306d29515f167e9458bd (patch)
tree7ef46828986c84e25bef51ad993fdb5f53f541ee /www-client/dillo
parentwww-client/dillo: fix doc dependencies (diff)
downloadgentoo-3f00c5083bfb37f1ed8b306d29515f167e9458bd.tar.gz
gentoo-3f00c5083bfb37f1ed8b306d29515f167e9458bd.tar.bz2
gentoo-3f00c5083bfb37f1ed8b306d29515f167e9458bd.zip
www-client/dillo: add 3.1.1
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/Manifest1
-rw-r--r--www-client/dillo/dillo-3.1.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
index 981e70c1e5e0..7257e107a85b 100644
--- a/www-client/dillo/Manifest
+++ b/www-client/dillo/Manifest
@@ -1,2 +1,3 @@
DIST dillo-3.1.0-html-tests.tar.xz 46836 BLAKE2B cb5c4ac685bd816cb4adf416d42be1e10de2289ba9180dc2c3181353448ee9a3c043e39e8cede06ba1417f822678bfcea9b1cea73e76768a8934fbd90fa8b00f SHA512 af8625602aae52b209eb3d60fd536c8d5a630b36010fece933e77ab990f48e6d14e4b3bc4fda8df8e5e17e01990bebea3fa343a2e14ae8238b6486d658d6bbd2
DIST dillo-3.1.0.tar.bz2 994610 BLAKE2B 02e5cd44163e5f066cbccf05a497439db6b7525cf612577908d435414f8a3dbbb4d7ab6a9345709dde5b278373f9d42f5a9f4143a32d5bcc49e2e4a7258a0f6d SHA512 c8a2ea420c2d70a60acc242cf15bd90e65c265db434f9693a1a8e7343cde1eb02c8144293c547582fb0985f306a07f11a7eb8e30c35ec2418131f717b1fda01f
+DIST dillo-3.1.1.tar.bz2 1026711 BLAKE2B 81fbaf527f89160bfddf4bc51048dab8f1487b735e6d9cb9679deb46cda666158bb6b0d469ec28691167cd9d9657a12f5d5f5ed5b6c1cb0102963d611b4e2ece SHA512 2f6ad315c246638e91af13fbeb8a846b756c222aaf2275efb1bff6bae08130bb4b8fda9c09cd33925911c424fe536cf7a587e6657de9a13d63733714c86533c1
diff --git a/www-client/dillo/dillo-3.1.1.ebuild b/www-client/dillo/dillo-3.1.1.ebuild
new file mode 100644
index 000000000000..b40a1c5d1e76
--- /dev/null
+++ b/www-client/dillo/dillo-3.1.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs virtualx xdg-utils
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://dillo-browser.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dillo-browser/dillo.git"
+else
+ SRC_URI="https://github.com/dillo-browser/dillo/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc +gif +jpeg mbedtls +png +ssl +openssl +xembed"
+REQUIRED_USE="
+ ssl? ( || ( openssl mbedtls ) )
+"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3:1
+ sys-libs/zlib
+ x11-libs/libX11
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.2:= )
+ ssl? (
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+ test? (
+ media-gfx/imagemagick
+ x11-apps/xwd
+ x11-apps/xwininfo
+ )
+
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ app-text/texlive
+ )
+"
+
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug rtfl)
+ $(use_enable gif)
+ $(use_enable jpeg)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable png)
+ $(use_enable ssl tls)
+ $(use_enable xembed)
+ --enable-ipv6
+ )
+
+ use test && myeconfargs+=( --enable-html-tests=yes )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # The test suite consistently fails with -jN in portage
+ virtx emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}