summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-15 18:16:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-15 18:33:54 -0700
commit9c60f686d350f72a1ed9b000adb8161227de21fa (patch)
treee40bef7934a884877fe67ff7991f3f8b01a9ae6a /www-client/chromium
parentwww-client/chromium: bump 91.0.4472.106 ppc64le patchset (diff)
downloadgentoo-9c60f686d350f72a1ed9b000adb8161227de21fa.tar.gz
gentoo-9c60f686d350f72a1ed9b000adb8161227de21fa.tar.bz2
gentoo-9c60f686d350f72a1ed9b000adb8161227de21fa.zip
www-client/chromium: add ppc64le support to 92.0.4515.51
but no ~ppc64 keyword. Chromium is always unstable-keyworded on ppc64, we don't want users to get ver 92.x and use stable channel by default. users are welcome to accept-keywords 92.x branch for testing. Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-92.0.4515.51.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-92.0.4515.51.ebuild b/www-client/chromium/chromium-92.0.4515.51.ebuild
index 744bf4df8d58..338eee1281c8 100644
--- a/www-client/chromium/chromium-92.0.4515.51.ebuild
+++ b/www-client/chromium/chromium-92.0.4515.51.ebuild
@@ -15,10 +15,12 @@ DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://chromium.org/"
PATCHSET="6"
PATCHSET_NAME="chromium-$(ver_cut 1)-patchset-${PATCHSET}"
+PPC64LE_PATCHSET="91-ppc64le-6"
SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.xz
https://files.pythonhosted.org/packages/ed/7b/bbf89ca71e722b7f9464ebffe4b5ee20a9e5c9a555a56e2d3914bb9119a6/setuptools-44.1.0.zip
https://github.com/stha09/chromium-patches/releases/download/${PATCHSET_NAME}/${PATCHSET_NAME}.tar.xz
- arm64? ( https://github.com/google/highway/archive/refs/tags/0.12.1.tar.gz -> highway-0.12.1.tar.gz )"
+ arm64? ( https://github.com/google/highway/archive/refs/tags/0.12.1.tar.gz -> highway-0.12.1.tar.gz )
+ ppc64? ( https://dev.gentoo.org/~gyakovlev/distfiles/${PN}-${PPC64LE_PATCHSET}.tar.xz )"
LICENSE="BSD"
SLOT="0"
@@ -243,6 +245,8 @@ src_prepare() {
)
fi
+ use ppc64 && eapply -p0 "${WORKDIR}/${PN}"-ppc64le
+
default
mkdir -p third_party/node/linux/node-linux-x64/bin || die
@@ -749,6 +753,9 @@ src_configure() {
append-cxxflags -flax-vector-conversions
fi
+ # highway/libjxl fail on ppc64 without extra patches, disable for now.
+ use ppc64 && myconf_gn+=" enable_jxl_decoder=false"
+
# Disable unknown warning message from clang.
tc-is-clang && append-flags -Wno-unknown-warning-option