summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-28 19:59:40 +0000
committerSam James <sam@gentoo.org>2024-01-28 20:00:33 +0000
commit388df0755c165a987ff032cd69f03803cc47815b (patch)
tree0a69ecf9fad86bb8e3e9e6629f0b51b42ccf2aef /www-client/chromium
parentdev-libs/libverto: Stabilize 0.3.2 arm, #923167 (diff)
downloadgentoo-388df0755c165a987ff032cd69f03803cc47815b.tar.gz
gentoo-388df0755c165a987ff032cd69f03803cc47815b.tar.bz2
gentoo-388df0755c165a987ff032cd69f03803cc47815b.zip
www-client/chromium: check tc-ld-is-lld for use_lld param
Make sure we enable the LLD toggle if the user has enabled LLD themselves rather than the ebuild doing it. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-120.0.6099.129.ebuild2
-rw-r--r--www-client/chromium/chromium-120.0.6099.224.ebuild2
-rw-r--r--www-client/chromium/chromium-121.0.6167.85.ebuild2
-rw-r--r--www-client/chromium/chromium-122.0.6261.6.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/www-client/chromium/chromium-120.0.6099.129.ebuild b/www-client/chromium/chromium-120.0.6099.129.ebuild
index 91a4aac3089a..e54129b80752 100644
--- a/www-client/chromium/chromium-120.0.6099.129.ebuild
+++ b/www-client/chromium/chromium-120.0.6099.129.ebuild
@@ -723,7 +723,7 @@ chromium_configure() {
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
# Force lld for lto and pgo builds, otherwise disable, bug 641556
- if needs_lld || use lto || use pgo; then
+ if needs_lld || tc-ld-is-lld || use lto || use pgo; then
myconf_gn+=" use_lld=true"
else
myconf_gn+=" use_lld=false"
diff --git a/www-client/chromium/chromium-120.0.6099.224.ebuild b/www-client/chromium/chromium-120.0.6099.224.ebuild
index fc235299b7a4..befc4cb52737 100644
--- a/www-client/chromium/chromium-120.0.6099.224.ebuild
+++ b/www-client/chromium/chromium-120.0.6099.224.ebuild
@@ -723,7 +723,7 @@ chromium_configure() {
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
# Force lld for lto and pgo builds, otherwise disable, bug 641556
- if needs_lld || use lto || use pgo; then
+ if needs_lld || tc-ld-is-lld || use lto || use pgo; then
myconf_gn+=" use_lld=true"
else
myconf_gn+=" use_lld=false"
diff --git a/www-client/chromium/chromium-121.0.6167.85.ebuild b/www-client/chromium/chromium-121.0.6167.85.ebuild
index b763322aa50c..1234ddf241c6 100644
--- a/www-client/chromium/chromium-121.0.6167.85.ebuild
+++ b/www-client/chromium/chromium-121.0.6167.85.ebuild
@@ -764,7 +764,7 @@ chromium_configure() {
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
# 641556: Force lld for lto and pgo builds, otherwise disable
- if needs_lld || use lto || use pgo; then
+ if needs_lld || tc-ld-is-lld || use lto || use pgo; then
myconf_gn+=" use_lld=true"
else
# This doesn't prevent lld from being used, but rather prevents gn from forcing it
diff --git a/www-client/chromium/chromium-122.0.6261.6.ebuild b/www-client/chromium/chromium-122.0.6261.6.ebuild
index 6fd300f560f1..cd22863412fc 100644
--- a/www-client/chromium/chromium-122.0.6261.6.ebuild
+++ b/www-client/chromium/chromium-122.0.6261.6.ebuild
@@ -285,7 +285,7 @@ needs_clang() {
needs_lld() {
# #641556: Force lld for lto and pgo builds, otherwise disable
# #918897: Temporary hack w/ use arm64
- [[ ${CHROMIUM_FORCE_LLD} == yes ]] || use lto || use pgo || use arm64
+ [[ ${CHROMIUM_FORCE_LLD} == yes ]] || tc-ld-is-lld || use lto || use pgo || use arm64
}
llvm_check_deps() {